If you are seeing “Loading…” on the search results, that probably means that something is failing during the AJAX call to retrieve data from the ILS driver.  You might get more information if you follow step 2 here:

 

http://vufind.org/wiki/ils_driver_troubleshooting

 

If that isn’t helpful, it’s probably easier to do some initial testing on a page that doesn’t involve AJAX, since it’s less complicated to add debug messages in the code and then see them  on the screen.  For example, if you go to the default “Holdings” tab of any record page, that should trigger a call to your driver’s getHolding() method, which may be easier to troubleshoot than getStatuses().

 

I hope this helps get you started – please let me know if you need more details!

 

- Demian

 

From: Byron Smith [mailto:byron@webwired.com.au]
Sent: Tuesday, June 28, 2011 8:39 AM
To: vufind-tech@lists.sourceforge.net
Subject: [VuFind-Tech] Testing VuFind Driver for ILS

 

Hi All,

 

I am currently trying to create a new driver for VuFind that connects to a new ILS called Evolve.  I have created it based off the Horizon driver since this is one of the few VuFind drivers I can find that connects to a MSSQL database.  Does anyone have information on the best way to go about testing this new driver I am creating?  I have set the driver up within VuFind and restarted both Vufind and Apache but I am just getting the word ‘loading’ returning where VuFind is linking back to the ILS.  What is the best way to tell if I have at least made a successful connection to the database and if any data is returning?  Thanks to anyone who might be able to help!

 

Cheers,

 

Byron