Content-Type: multipart/related; boundary="_005_48eae988b3844ce7bb4c10671649ec8fCO1PR07MB444namprd07pro_"; type="multipart/alternative" --_005_48eae988b3844ce7bb4c10671649ec8fCO1PR07MB444namprd07pro_ Content-Type: multipart/alternative; boundary="_000_48eae988b3844ce7bb4c10671649ec8fCO1PR07MB444namprd07pro_" --_000_48eae988b3844ce7bb4c10671649ec8fCO1PR07MB444namprd07pro_ Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable I'm in the process of migrating servers this January so I'm taking the oppo= rtunity to upgrade vufind to version 2. I'm attempting a clean install but = I'm using Tomcat as the java web wrapper instead of Jetty. I'm running wind= ows server 2012. Here's what I'm able to do and not do: 1. I can start tomcat (v 7.0) 2. I can browse to http://localhost:8080/solr/ but it only shows an a= dmin link which, when clicked, doesn't work (see 3) 3. http://localhost:8080/solr/admin/ gives me a "missing core path" e= rror 4. http://localhost:8080/solr/admin/multicore returns an xml response= with status of "0" 5. I can't browse to any of my indexes in solr. 6. The error logs (attached) show "Error loading class 'solr.ICUToken= izerFactory'" a. Related to trying to solve this here are some relevant details: i. I se= t solr home to in the web.xml to point to c:\solr which appears to be succe= ssful according to log files ii. In c:= \solr\solr.xml I set and have = the relevant cores in place - sharedLib should ideally point the cores to t= he c:\solr\lib folder for all relevant jar libraries, which it appears to d= o. iii. As pe= r the solr/contrib/analysis-extras/README.txt, I added all of the necessary= relevant jar files into the lib folder and the ones from the vufind solr l= ib folder. iv. When I = start tomcat and look at the log files, all of those files actually load. I= mmediately follow them loading it tries to load some schema stuff and fails= on the solr.ICUTolkenizationFactory "Caused by: java.lang.ClassNotFoundExc= eption: solr.ICUTokenizerFactory" I attached the a log file of me simply starting the tomcat server and that'= s all. The Severe errors are in there. Any ideas? Am I missing something? W= hat do I try next? Mike Beccaria Systems Librarian Head of Digital Initiative Paul Smith's College 518.327.6376 mbeccaria@paulsmiths.edu [Description: cid:image001.png@01CB5644.9B8B8CD0]Become a friend of Paul Smith's Library on Facebook today! --_000_48eae988b3844ce7bb4c10671649ec8fCO1PR07MB444namprd07pro_ Content-Type: text/html; charset="us-ascii" Content-Transfer-Encoding: quoted-printable

I’m in the process = of migrating servers this January so I’m taking the opportunity to up= grade vufind to version 2. I’m attempting a clean install but I’= ;m using Tomcat as the java web wrapper instead of Jetty. I’m running windows= server 2012. Here’s what I’m able to do and not do:=

1. = ;      I can start tomca= t (v 7.0)

2. = ;      I can browse to http://localhost:8080/solr/ but= it only shows an admin link which, when clicked, doesn’t work (see 3= )

3. = ;      http://localhost:8080/solr/admin/ gives me= a “missing core path” error

4. = ;      http://localhost:8080/solr/admin/mult= icore returns an xml response with status of “0”=

5. = ;      I can’t bro= wse to any of my indexes in solr.

6. = ;      The error logs (a= ttached) show “Error loading class 'solr.ICUTokenizerFactory'”<= o:p>

a.  &= nbsp;    Related to trying= to solve this here are some relevant  details:

  &nb= sp;            =             &nb= sp;            =             &nb= sp;          i.  = ;    I set solr home to in the web.xml to point to c:\solr which appears to b= e successful according to log files

  &nb= sp;            =             &nb= sp;            =             &nb= sp;        ii. &nbs= p;    In c:\solr\solr.xml I set <solr persistent=3D"true" shared= Lib=3D"lib"> and have the relevant cores in place – sharedLib should ideally point the cores to the c:\= solr\lib folder for all relevant jar libraries, which it appears to do.

  &nb= sp;            =             &nb= sp;            =             &nb= sp;       iii. &nb= sp;    As per the solr/contrib/analysis-extras/README.txt, I added all of the= necessary relevant jar files into the lib folder and the ones from the vufind solr lib folder= .

  &nb= sp;            =             &nb= sp;            =             &nb= sp;      iv. &nbs= p;    When I start tomcat and look at the log files, all of those files actua= lly load. Immediately follow them loading it tries to load some schema stuff and fails on the so= lr.ICUTolkenizationFactory “Caused by: java.lang.ClassNotFoundExcepti= on: solr.ICUTokenizerFactory”

 <= /p>

I attached the a log file= of me simply starting the tomcat server and that’s all. The Severe e= rrors are in there. Any ideas? Am I missing something? What do I try next?

 <= /p>

Mike Beccaria<= /span>

Systems Librarian

Head of Digital Initiativ= e

Paul Smith's College=

518.327.6376

mbeccaria@paulsmiths.edu<= o:p>

3D"Desc=Become a friend of Paul Smith's Li= brary on Facebook today!

--_000_48eae988b3844ce7bb4c10671649ec8fCO1PR07MB444namprd07pro_-- --_005_48eae988b3844ce7bb4c10671649ec8fCO1PR07MB444namprd07pro_ Content-Type: image/png; name="image001.png" Content-Description: image001.png Content-Disposition: inline; filename="image001.png"; size=359; creation-date="Thu, 05 Dec 2013 16:45:05 GMT"; modification-date="Thu, 05 Dec 2013 16:45:05 GMT" Content-ID: Content-Transfer-Encoding: base64 iVBORw0KGgoAAAANSUhEUgAAACYAAAAmCAIAAAAnX375AAAAAXNSR0IArs4c6QAAASFJREFUWEdj ZGBgKO3aceL8AyCD1sDCUKG7zIPRNnIGrW1CNh9oKxM97QPaBQxOelsJtHUArKR+XAJjCzmyMBMm 1awE2tRa6IKZMqr796DZSp2AxWUf1rRJBStJso86yQdreOLJe5T6Ei2xwG0CRiEEYdpNqZVY04tz 3BxgkoEjNDXUt5JgcU19KwmWoCPDSmZ5XR+CQYGmAJhKZSQFFnaF3HrwDjOHAAUhUhASqPLJiw/I JpBT4JGU92lV4JEUTiMj+ZATl8BghJdzmMkHs5BDKxzItBIeeZhJCVja4Y/akRGXo74kKYMTr3hk BCwiX+JqxRAMMbTSAGt7B9IbgRg1MgJ2ZPiSCsU6Wvoi2Kik1EqC6Rmz3cQIFKLncMHh5RkAl+Fn GXNfWRcAAAAASUVORK5CYII= --_005_48eae988b3844ce7bb4c10671649ec8fCO1PR07MB444namprd07pro_--