Make sure you have also loaded the most recent Voyager.ini.  There has been an addition to the Voyager.ini file (specifically, the port number).

 

If you have the most recent of both, try using the svn status command to make sure there aren't any other missing files or conflicts.

 

Andrew

 

From: John Furfey [mailto:jfurfey@mbl.edu]
Sent: Friday, August 24, 2007 2:21 PM
To: Chris Delis
Cc: Andrew Nagy; vufind-general@lists.sourceforge.net
Subject: Re: [VuFind-General] voyager connection issue

 

loaded the most recent voyager driver from the subversion repos, now i'm getting this error:

 

Fatal error: Uncaught exception 'PDOException' with message 'could not find driver' in /usr/local/vufind/web/services/Search/Drivers/Voyager.php:49 Stack trace: #0 /usr/local/vufind/web/services/Search/Drivers/Voyager.php(49): PDO->__construct('oci:dbname=(DES...', 'ro_whoidb', 'ro_whoidb') #1 /usr/local/vufind/web/services/Search/CatalogConnection.php(30): Voyager->__construct() #2 /usr/local/vufind/web/services/Record/Record.php(174): CatalogConnection->__construct('Voyager') #3 /usr/local/vufind/web/services/Record/Record.php(88): getHolding('65425') #4 /usr/local/vufind/web/index.php(86): Record->__construct() #5 {main} thrown in /usr/local/vufind/web/services/Search/Drivers/Voyager.php on line 49

 

 

On Aug 24, 2007, at 2:03 PM, Chris Delis wrote:



On Fri, Aug 24, 2007 at 01:56:22PM -0400, John Furfey wrote:

upon editing voyager.ini, does the application need to be restarted?

 

 

No, it appears the configuration file is read each time a connection

is made. 

 

Chris

 

On Aug 23, 2007, at 1:48 PM, Andrew Nagy wrote:

 

Make sure you have the new port option in your Voyager.ini file.   

If this still does not work for you I would try using the same  

connection information in some database tool such as DBVisualizer  

to ensure that it is able to connect.  Also make sure there are no  

firewall rules to  block access.

 

Andrew

 

 

 

From: vufind-general-bounces@lists.sourceforge.net [mailto:vufind- 

general-bounces@lists.sourceforge.net] On Behalf Of John Furfey

Sent: Thursday, August 23, 2007 12:00 PM

Subject: [VuFind-General] voyager connection issue

 

I'm still getting this error when trying to open a full record:

 

Fatal error: Call to a member function prepare() on a non-object  

in /usr/local/vufind/web/services/Search/Drivers/Voyager.php on  

line 69

 

I've confirmed with our ils admin that the settings in voyager.ini  

are correct.

 

I'm running VuFind 0.6 on Ubuntu.  Is there anything else besides  

the voyager.ini file that could be causing this error?

 

 

 

 

------------------------------------------------------------

John Furfey

Digital Systems and Services Coordinator

MBLWHOI Library

Woods Hole MA  02543 USA

PHONE:  508-289-7435

EMAIL:  jfurfey@mbl.edu

 

 

 

 

 

 

------------------------------------------------------------

John Furfey

Digital Systems and Services Coordinator

MBLWHOI Library

Woods Hole MA  02543 USA

PHONE:  508-289-7435

EMAIL:  jfurfey@mbl.edu

 

 

 

 

 

-------------------------------------------------------------------------

This SF.net email is sponsored by: Splunk Inc.

Still grepping through log files to find problems?  Stop.

Now Search log events and configuration files using AJAX and a browser.

Download your FREE copy of Splunk now >>  http://get.splunk.com/

_______________________________________________

VuFind-General mailing list

 

 

------------------------------------------------------------

John Furfey

Digital Systems and Services Coordinator

MBLWHOI Library

Woods Hole MA  02543 USA

PHONE:  508-289-7435

EMAIL:  jfurfey@mbl.edu

http://www.mblwhoilibrary.org