Hi All


I still have this problem with VuFind and, although it initially looked like an Aleph driver problem, after numerous emails with Vasek (would has been very patient and helpful) it appears this is not the case.  These are the symptoms:


         On the search results page the call number and location show loading and then are hidden

         On the record page no holdings are displayed

         With debug set to true no logging takes place through the Aleph driver (latest commit installed)

         Checking the traffic on the nic with TCPDump VuFind is silent, no requests are being sent to Aleph

         Submitting requests manually through a web browser (on the VuFind server) return results as expected.

         On the search results page no book cover images are displayed, config is set to Google (Not sure if this is related)


Firebug shows the following json request:



Is this formatted correctly for VuFind?  The only clue I have is in the Apache logs where I get:

Notice: Undefined offset: 1 in /usr/local/vufind2/module/VuFind/src/VuFind/ILS/Driver/Aleph.php on line 740


Installation details:

Virtual server running Debian GNU/Linux 6.0.7 (squeeze) as guest OS

VuFind 2.0.1 + latest commit of Aleph driver


I am at a lost as what to try next.


Thanks - Paul


From: Demian Katz [mailto:demian.katz@villanova.edu]
Sent: 25 July 2013 18:05
To: GRIFFITHS, Paul; vufind-general@lists.sourceforge.net
Cc: vufind tech
Subject: RE: Missing holdings data


I’m copying this to the vufind-tech list since there are some Aleph users there, and I want to be sure they see this in case they’re not following the general list.


The Aleph driver packaged with VuFind 2.0 is significantly different from the 1.x Aleph driver (it adds a lot of functionality and was substantially rewritten along the way).  Perhaps some of those changes have introduced a compatibility problem.  Hopefully one of our resident Aleph experts can offer some troubleshooting advice.  If you don’t hear anything in a couple of days, remind me and I’ll forward your query directly to the main author of the 2.0 driver.


- Demian


From: GRIFFITHS, Paul [mailto:pgriffiths@glos.ac.uk]
Sent: Thursday, July 25, 2013 11:29 AM
To: vufind-general@lists.sourceforge.net
Subject: [VuFind-General] Missing holdings data




I have a clean install of vufind 2.01 running on a virtual debian box but cannot get any holdings data to display.  I have previously had vufind 1.4 running on a virtual windows box and the holdings data displayed ok.


Our LMS is Aleph and both Aleph and vufind are on the same domain (glos.ac.uk), the site url in the config file is the domain name although I have tried IP and commenting out for auto detection and debug is turned off.  The Aleph config has been checked and is the same for the v1.4 that worked so I’m pretty sure it’s not that.


Any suggestions of where to look next would be appreciated.


Thanks - Paul



Paul Griffiths

Library Information Technologist

Library and Information Services

University of Gloucestershire