Yeah, I did recreate my index after these changes.

I wonder, though, if the cause of my problem is simply my local import configuration.


We use the first instance of our 035 field as our vufind key value. It is defined as:

id = 035a, (, first


But for searching, we want to index all of our 035 field values, and so I created a new vufind field as follows:


ctrlnum = 035a, (


thinking this would index ALL of our 035 values.

That’s why I defined the ctrlnum in schema.xml as a multivalued=”true”


But what I am finding is that I am still only getting appropriate hits on 035 when it is the record id.


So, does the real problem stem from vufind not indexing the same marc field in 2 different ways?

Or do I need to replace “first” with something else, rather than just drop it in my new field?


Thanks again,





From: Demian Katz []
Sent: Friday, April 18, 2014 5:46 PM
To: Shepard, Thomas - 1150 - MITLL;;
Subject: RE: Making new marc fields searchable


Did you reindex all of your records after step 2?

If it's not that simple, have you tried turning on debug to see what kind of queries are being generated by VuFind? That might offer a clue or point of departure for experimentation with manual query generation.

- Demian

From: Shepard, Thomas - 1150 - MITLL []
Sent: Friday, April 18, 2014 4:24 PM
Subject: [VuFind-Tech] Making new marc fields searchable

I am trying to include our 035 field searchable as part of our isbn searches.

I have no problem setting up a facet with values from 035, and I can configure the search dropdown options to include this field, but I get no hits back then I search on values from this field.

After perusing the web, I came across responses to Mansur Ali’s similar question and so also edited searchspecs.yaml to include this field.

Oh, and yes, 035 is also our ID field, but we have multiple 035 fields in any given record and our vufind importer takes the first one.


In summary, I did the following:

1.       In schema.xml, I created a ctrlnum field with type=”string” indexed=”true” stored=”true” multivalued=”true”

2.       In, I defined ctrlnum as ctrlnum = 035a, (

3.       In search.ini, I defined ctrlnum=”Control035”

4.       In searchspecs.yaml, I added ctrlnum as follows:



    - isbn

    - issn

    - ctrlnum



      - [and, 100]

      - [or, ~]


      - [and, 100]

      - [or, ~]


      - [and, 100]

      - [or, ~]


Am I missing a step?

Oh, I also tried this by changing ctrlnum to type=”isn” but still no search results unless I search for an isbn (from the 020 field)


Thanks in advance,

Thom Shepard


Thom Shepard

MIT Lincoln Lab
244 Wood St.

Lexington, MA 01523

781 981 0370781 981 0370



Send SMS

Add to Skype

You'll need Skype CreditFree via Skype