Problems with #include. Is it a bug?

  • vinicius

    vinicius - 2006-02-14

    I'm trying to use the include directive to insert a content of another file in my template. I tried many possibilities unsuccessfully. I got a simple example from velocity site and it worked very well with Texen. I'd like to know if there is a work around to solve this problem.

    Thanks in advice.

    test.vm content:


    test.txt content

    Only a simple test
    Error message

    [vpp:copy] [error] Cannot process content resource : org.apache.velocity.exception.ResourceNotFoundException: FileResourceLoader Error: cannot find resource test.txt
    [vpp:copy] [error] ResourceManager : unable to find resource 'test.txt' in any resource loader.
    [vpp:copy] [error] #include(): cannot find resource 'test.txt', called from template vpp at (3, 1)


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks