Installation Errors

  • Jim Kronebusch

    Jim Kronebusch - 2009-02-06

    I am installing on Ubuntu 8.04 and have successfully ran ./configure, but get the following errors when running make:

    root@ocs:/home/administrator/VPMS Info/vmpsd# make
    cd . && autoheader
    autoheader2.50: WARNING: Using auxiliary files such as `acconfig.h', `'
    autoheader2.50: WARNING: and `', to define templates for `'
    autoheader2.50: WARNING: is deprecated and discouraged.
    autoheader2.50: WARNING: Using the third argument of `AC_DEFINE' and
    autoheader2.50: WARNING: `AC_DEFINE_UNQUOTED' allows one to define a template without
    autoheader2.50: WARNING: `acconfig.h':
    autoheader2.50: WARNING:   AC_DEFINE([NEED_FUNC_MAIN], 1,
    autoheader2.50:                 [Define if a function `main' is needed.])
    autoheader2.50: WARNING: More sophisticated templates can also be produced, see the
    autoheader2.50: WARNING: documentation.
    rm -f stamp-h1
    cd . && /bin/bash ./config.status config.h
    config.status: creating config.h
    config.status: config.h is unchanged
    make  all-am
    make[1]: Entering directory `/home/administrator/VPMS Info/vmpsd'
    source='vmpsd.c' object='vmpsd-vmpsd.o' libtool=no \         DEPDIR=.deps depmode=none /bin/bash ./depcomp \         gcc -DHAVE_CONFIG_H -I. -I. -I.    -DSYSCONFDIR="\"/usr/local/etc\"" -g -O2 -c -o vmpsd-vmpsd.o `test -f 'vmpsd.c' || echo './'`vmpsd.c
    /bin/bash: ./depcomp: No such file or directory
    make[1]: *** [vmpsd-vmpsd.o] Error 127
    make[1]: Leaving directory `/home/administrator/VPMS Info/vmpsd'
    make: *** [all] Error 2

    I am not sure why I get the error.  I do not see a depcomp file in the root of the install directory, should there be?  Any help would be appreciated.


    • Jim Kronebusch

      Jim Kronebusch - 2009-02-06

      I should mention I have just downloaded the newest package on sourceforge of vmpsd-1.4.tar.gz release on 2/1/09.


    • Anonymous - 2009-02-08

      Hi Jim,

      I ran into the same problem today. Just execute the following command in the source dir:

      automake -a -c

      It creates the depcomp shell script. After that you can run make again.

      best regards,


    • Jim Kronebusch

      Jim Kronebusch - 2009-02-09

      Thank you very much, worked like a charm.  This sounds like it would be a very handy step to include in the INSTALL file.  I spent a few hours trying to figure this out.

      Something on the lines of:

      automake -a -c
      make install

      But maybe this is only a problem on Ubuntu or maybe other Debian based Linux's.

      Thanks again,



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks