TK::ToolBar

Help
2010-07-08
2013-01-21
  • Jim Kubicek

    Jim Kubicek - 2010-07-08

    I was hoping to get some help with this error I am encountering while trying to install this module for use with VisualCamel. I used to use The GUILoft, but that has long since died out and I have been unable to find a good GUI app for Perl.  Anywho, here is the issue:
    Installing 2 packages failed

    ERROR: File conflict for 'C:/Perl/site/lib/Tk/demos/widtrib/cursor.pl'.
        The package Tk has already installed a file that package Tk-CursorControl
        wants to install.

    I try to install just TK::CursorControl and get the same error, obviously. Does anyone have a workaround or fix?

    Thanks,

    Jim K

     
  • Anonymous - 2010-07-14

    what operating system and perl version are you using?

     
  • Jim Kubicek

    Jim Kubicek - 2010-07-14

    Windows Vista Ultimate

    C:\>uname -X

    System = Interix
    Node = ITADMINISTRATOR
    Release = 6.0
    Version = 10.0.6030.0
    Machine = x86
    Processor = AMD_x86_Family15_Model107_Stepping2
    HostSystem = Windows
    HostRelease = 6.0
    HostVersion = SP1

    C:\>perl -v

    This is perl, v5.10.0 built for MSWin32-x86-multi-thread
    (with 9 registered patches, see perl -V for more detail)

    Copyright 1987-2007, Larry Wall

    Binary build 1005  provided by ActiveState http://www.ActiveState.com
    Built May 24 2009 12:17:36

    Perl may be copied only under the terms of either the Artistic License or the
    GNU General Public License, which may be found in the Perl 5 source kit.

    Complete documentation for Perl, including FAQ lists, should be found on
    this system using "man perl" or "perldoc perl".  If you have access to the
    Internet, point your browser at http://www.perl.org/, the Perl Home Page.

    C:\>

     
  • Brett Carroll

    Brett Carroll - 2010-07-14

    Your OS and perl environment should be fine (I am running VisualCamel on Windows XP/perl 5.10.0)

    Are you using ppm to install Tk::Toolbar, copying the .pm file to the \perl\site\lib\Tk directory, or using some other method?

     
  • Jim Kubicek

    Jim Kubicek - 2010-07-14

    I am using the ActiveState PPM to install.

     
  • Brett Carroll

    Brett Carroll - 2010-07-14

    have you tried using -force to install Tk::Toolbar?

    ppm install --force Tk::Toolbar
    
     
  • Jim Kubicek

    Jim Kubicek - 2010-07-14

    I have not. I will try now.

     
  • Jim Kubicek

    Jim Kubicek - 2010-07-14

    Well that seemed to work for the install.  Thank you very much. I was using the PPM GUI and there is no force option available. I really did start my career in Unix, but I have obviously been in Windows tooooo long now.

    Thanks again stardogg!

     
  • Anonymous - 2011-03-27

    Please let me know what you think of VisualCamel.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks