Bug in "manage items" of Mor...

Bugs
Jason
2011-08-25
2013-04-24
  • Jason

    Jason - 2011-08-25

    Hello,  I am able to use MoreInfo  fully,  the only issue is an error when going to Manage Items in the More Info component.  Here it is:

    500 - An error has occurred.

    Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=' SQL=SELECT a.id, a.tid, a.val, a.lang,t.name AS type_name,l.title AS language_title,COUNT(DISTINCT b.content_id) AS article_count FROM `j16_moreinfo_data` AS a LEFT JOIN `j16_moreinfo_type` AS t ON t.id = a.tid LEFT JOIN `j16_languages` AS l ON l.lang_code = a.lang LEFT JOIN `j16_moreinfo_binding` AS b ON b.moreinfo_id = a.id GROUP BY a.id ORDER BY a.tid asc Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=' SQL=SELECT a.id, a.tid, a.val, a.lang,t.name AS type_name,l.title AS language_title,COUNT(DISTINCT b.content_id) AS article_count FROM `j16_moreinfo_data` AS a LEFT JOIN `j16_moreinfo_type` AS t ON t.id = a.tid LEFT JOIN `j16_languages` AS l ON l.lang_code = a.lang LEFT JOIN `j16_moreinfo_binding` AS b ON b.moreinfo_id = a.id GROUP BY a.id ORDER BY a.tid asc Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=' SQL=SELECT a.id, a.tid, a.val, a.lang,t.name AS type_name,l.title AS language_title,COUNT(DISTINCT b.content_id) AS article_count FROM `j16_moreinfo_data` AS a LEFT JOIN `j16_moreinfo_type` AS t ON t.id = a.tid LEFT JOIN `j16_languages` AS l ON l.lang_code = a.lang LEFT JOIN `j16_moreinfo_binding` AS b ON b.moreinfo_id = a.id GROUP BY a.id ORDER BY a.tid asc Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=' SQL=SELECT a.id, a.tid, a.val, a.lang,t.name AS type_name,l.title AS language_title,COUNT(DISTINCT b.content_id) AS article_count FROM `j16_moreinfo_data` AS a LEFT JOIN `j16_moreinfo_type` AS t ON t.id = a.tid LEFT JOIN `j16_languages` AS l ON l.lang_code = a.lang LEFT JOIN `j16_moreinfo_binding` AS b ON b.moreinfo_id = a.id GROUP BY a.id ORDER BY a.tid asc
    Return to Control Panel

    this is admin error, and I am using the MInima admin template - so I tried switching back to default admin template and still got the same error.

    cheers and thanks for your help
    jason

     
  • Johan Ekblad

    Johan Ekblad - 2011-08-26

    Hi, thank's for using MoreInfo! For some reason we specified den charset UTF8 for the moreinfo_type table. You are probably using another charset as default, that's why the comparation breaks in mysql. I will remove this UTF8 specification and build a new release.

    In order for you to fix this I whould do the following in mysql (assuming you use the default jos-prefix for your joomla database):

    drop table jos_moreinfo_type;
    create table jos_moreinfo_type (
      `id` INT(11) UNSIGNED NOT NULL AUTO_INCREMENT,
      `name` VARCHAR(25) NOT NULL,
      `urlPrefix` VARCHAR(20),
      `urlCheck` INT(1),
      `alignment` VARCHAR(20),
      `linkable` INT(1) NOT NULL DEFAULT 1,
      PRIMARY KEY  (`id`)
    );
    insert into jos_moreinfo_type (`name`,`urlPrefix`,`urlCheck`,`alignment`,`linkable`)
    values
            ('phone','tel:',0,'left',1),
            ('www','',1,'left',1),
            ('mail','mailto:',0,'left',1),
            ('speak','tel:',0,'right',1),
            ('address','',0,'',0);

     
  • Jason

    Jason - 2011-08-26

    Awesome! OK then, great I will try this SQL command and see what happens :) cheers and thanks very much for your help
    Jason

     
  • Jason

    Jason - 2011-09-07

    OK, here is an update.  I was moving my development site to a different location on the server, using akeeba backup and while restoring the akeeba backup,  there was an option to "Force UTF-8 Collation" or something like that in the database.  Checking that box did the trick,  along with the updated version.
    cheers
    Jason

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks