#37 vncserver -depth=16 causes error in vncviewer session

None
closed-wont-implement
DRC
TurboVNC (4)
5
2014-08-05
2013-01-02
Anonymous
No

Starting a (TurboVNC) vncserver with "depth=16" will generate an error in the TurboVNC vncviewer when launching a 3D app. Setting -depth=24 solved the problem. Perhaps an extra line or two in the docs would spare others the tail-chasing I experienced.

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2013-01-02
    • summary: Value of -depth=16 causes error in vncviewer session --> vncserver -depth=16 causes error in vncviewer session
     
  • DRC

    DRC - 2013-01-02
    • status: open --> closed-wont-fix
     
  • DRC

    DRC - 2013-01-02

    Why would you run TurboVNC with a depth of 16? That isn't the default setting, and there is absolutely no advantage to using TurboVNC with a lower color depth (in fact, it will perform worse than when using a depth of 24.) TurboVNC supports depth 16 and depth 8 only for completeness. The -depth option in TurboVNC is not documented in the User's Guide and is intended only for advanced use.

    The VirtualGL User's Guide says, under System Requirements: "X server configured to export True Color (24-bit or 32-bit) visuals". In the case of VNC, that means depth=24, and again, that's the default with TurboVNC. You tried to over-think it. Don't do that.

     
  • DRC

    DRC - 2014-04-28

    Ticket moved from /p/virtualgl/feature-requests/21/

    Can't be converted:

    • _milestone:
     
  • DRC

    DRC - 2014-04-28

    Ticket moved from /p/turbovnc/feature-requests/17/

    Can't be converted:

    • _milestone: None
     
  • DRC

    DRC - 2014-08-05
    • Status: closed-wont-fix --> closed-wont-implement
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks