[Help Needed] vglrun has no effect

Help
Chris
2011-07-26
2013-11-26
  • Chris

    Chris - 2011-07-26

    Hi,

    I am using a server running CentOS 5.6. The graphics card available is an Nvidia GeForce GTX 285. There is no monitor connected to the server.

    I wish to run OpenGL applications on the server, with all the rendering performed there, and view the results on a laptop using VNC (at the moment I am using TurboVNC, as recommended on the virtualGl website).

    My problem is as follows:

    When I run, for example, glxspheres without vglrun, the OpenGL renderer is the graphics card on my laptop. However, when I run glxspheres  using the command "./vglrun ./glxspheres", the rendering is still performed on my laptop. Changing the VGL_DISPLAY environment variable appears to have no effect on this, and neither does the -d option for vglrun.

    If I change the DISPLAY environment variable to the default (:0.0), then the rendering is carried out on the server, but I can not see the results.

    Does anyone have any suggestions? Any help would really be appreciated, as I really need to get this working within the next few days.

     
  • DRC

    DRC - 2011-07-27

    The fact that you are attempting to invoke VirtualGL using ./vglrun suggests that you are using some sort of custom install of it, so perhaps the problem is that it can't properly find the faker libraries.  I really recommend that, whenever possible, people use the pre-built binary packages for VirtualGL, as those are what we test and officially support.  VirtualGL is not really designed for "mass customization".

    Check for warning or error messages on the console regarding librrfaker.so and libdlfaker.so, as these probably indicate the dynamic linker's inability to find or load those libraries.  If those libraries can't be loaded, then the 3D application will behave as if VirtualGL isn't installed.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks