VirtualGL headless multi-nVidia - again

  • T0MA

    T0MA - 2011-11-30

    Hi all,
    I know there had been couple threads about this but I'm still not being able to get this running. I've spent now couple days reading all the documentation, mailing list archives etc. and pretty much tried everything with no luck.

    My setup is the following:

    Client machine <-NX-> Proxy running NX server <-VGLConnect-> GPU server running VirtualGL

    The GPU server has 8 Tesla M2050's and no screens attached to it and it's headless (no gdm/kdm..) RHEL 5. I'm following the documentation and configure VirtualGL with vglserver_config, setting no restrictions and not disabling XTEST. Here is the output:

    … Modifying /etc/security/console.perms to disable automatic permissions
        for DRI devices …
    … Modifying /etc/security/console.perms.d/50-default.perms to disable automatic permissions
        for DRI devices …
    … Creating /etc/modprobe.d/virtualgl.conf to set requested permissions for
        /dev/nvidia* …
    … Attempting to remove nvidia module from memory so device permissions
        will be reloaded …
    ERROR: Module nvidia is in use
    … Granting write permission to /dev/nvidia0 /dev/nvidia1 /dev/nvidia2 /dev/nvidia3 /dev/nvidia4 /dev/nvidia5 /dev/nvidia6 /dev/nvidia7 /dev/nvidiactl for all users …
    … Modifying /etc/X11/xorg.conf to enable DRI permissions for
        all users …
    … Setting default run level to 5 (enabling graphical login prompt) …

    Done. You must restart the display manager for the changes to take effect.

    IMPORTANT NOTE: Your system uses modprobe.d to set device permissions. You
    must execute rmmod nvidia with the display manager stopped in order for the
    new device permission settings to become effective.

    After I did rmmod nvidia I followed the mailing list advice and I ran
    nvidia-xconfig -a -use-display-device=None -virtual=1280x1024
    I open a new SSH session into the box but neither /opt/VirtualGL/bin/glxinfo nor xdpyinfo sees any screens on the machine. I'm not sure what I'm missing here.

    ># /opt/VirtualGL/bin/glxinfo -display :0.0 -c
    Error: unable to open display :0.0

    ># xdpyinfo -display :0.0
    xdpyinfo:  unable to open display ":0.0".

    I also tried setting in xorg.conf
    Option         "ConnectedMonitor" "DFP"
    as someone reported in the mailing list that this did the trick, but no luck here.

    Any help would be appreciated!

  • DRC

    DRC - 2011-11-30

    Please post this on virtualgl-users.  I am the only one who monitors these forums, and I'm not the expert on headless configurations.  There are people on the mailing lists who are better equipped to troubleshoot your issues.

  • T0MA

    T0MA - 2011-12-19

    Thanks, that was the first one I tried but the mailinglist didn't accept my post, kept throwing it back O.o


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks