no vglrun

Help
patula777
2012-02-27
2013-11-26
  • patula777

    patula777 - 2012-02-27

    Hi everybody,

    I have tried to build the VirtualGL from source on FreeBSD 9 amd64. I followed the building instructions and build it with
    > cmake -G "Unix Makefiles"
    > make
    > make install
    (without any errors)

    Unfortunately, afterwards I only have the following files:

    glxinfo*    glxspheres* nettest*    tcbench*    vglclient*  vglconnect*

    There is no vglrun which I need run VirtualBoxHeadless

    How can I build the vglrun ?

     
  • patula777

    patula777 - 2012-02-27

    Ok this is resolved.
    On FreeBSD you have to explicitely enable the server components by
    > cmake -DVGL_BUILDSERVER=1

     
  • DRC

    DRC - 2012-02-27

    Use the code in subversion trunk. There are numerous issues preventing the server code from running on FreeBSD until recently, which is why VGL_BUILDSERVER wasn't enabled by default on that platform. These issues have hopefully been fixed in trunk, so please test that code base. There is also a bug report for this, so please feel free to add comments there as well.

     
  • DRC

    DRC - 2012-02-27

    I should also add that the "evolving" version of the User's Guide (also in svn trunk) attempts to be more generic about referring to x86 Un*x systems, so it should now apply to FreeBSD. There is specific text in there now as well regarding setting up the 3D X Server using vglserver_config on FreeBSD.

     
  • DRC

    DRC - 2012-03-09

    1.1 beta with FreeBSD support has been released.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks