only low bitrates with mp3

Help
wincent
2005-10-21
2013-05-07
  • wincent

    wincent - 2005-10-21

    I put the mp3 lame encoder (lame_enc.dll) in VirtualDubMod folder, but I can't encode audio streams at high bitrates (i.e. 128 kbps). The highest bitrate available is about 64 kbps.
    I checked 'All formats'.
    The source audio is AC3 6 channels.

    Any idea ?
    Thanks for your help.

     
    • Jonathan

      Jonathan - 2008-12-14

      I'm not sure this is kosher, but it does work, at least for VDM in my installation of Windows XP SP2.  In the C:\Windows\System32 folder there are two native Mp3 codecs, L3CODECA.ACM and L3CODECP.ACM.  At least I think the second one is L3CODECP; whatever it is, it isn't L3CODECA to begin with, but it is the "Professional" version of the codec, and it allows encoding to much higher bitrates (e.g. 128, 192, etc.)  You have to disable the non-professsional version of the codec by renaming it to something like L3CODECA.ACM.OLD.  Then you can rename the other one L3CODECA.ACM, and Windows itself and VDM with recognize and use it by native preference.  You don't have to change anything else.

      After doing this, you can select MPEG-Layer 3 for audio compression of the active stream, and then check the "Show All Formats" box.  You can then select the highest bitrate (with the appropriate sampling rate) you think you need.

      Both of the L3CODEC .acm files came with my Windows installation, so it seems as though it should be OK to use the Professional version.  However, I have not discovered any other way to do so than the renaming method described above.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks