CPU intel E3-1230V2, opencl mode, error

ngagewj
2013-07-16
2013-09-07
  • ngagewj

    ngagewj - 2013-07-16

    platform : CPU-intel E3-1230V2 GPU-NVIDIA GTX 660
    the solution works at OpenMP mode very well, and works at OpenCL mode with GTX 660 very well, but cannot work at OpenCL mode with E3-1230V2.
    (AMD phenom II x4 955 cpu tested , opencl/openmp mode OK;
    ATI HD 4870 adapter tested, opencl double pricision mode failed;).

    need help...

     
    Last edit: ngagewj 2013-07-17
  • ngagewj

    ngagewj - 2013-07-16

    OpenCL mode with E3-1230V2 , error:
    case CL_DEVICE_NOT_AVAILABLE: throw device_not_available();
    Microsoft C++ exception: viennacl::ocl::device_not_found at memory location 0x03ebe1ec..

    intel Xeon X5650 tested, opencl mode failed, the same error.

     
    Last edit: ngagewj 2013-07-16
  • Karl Rupp

    Karl Rupp - 2013-08-19

    Hi,

    sorry for the HUGE delay, apparently my email notification settings for new forum posts got reset when sourceforge updated the UI :-/

    Which SDK do you use? If you're using the Intel SDK, the CPU may not be supported: http://stackoverflow.com/questions/15499533/error-cl-device-not-available-when-calling-clcreatecontext-intel-core2duo-inte
    Could you please consider installing the AMD OpenCL SDK? Our experience is that it works well even with an Intel CPU (sometimes even better than with the Intel OpenCL SDK)

    Best regards,
    Karli

     
  • ngagewj

    ngagewj - 2013-08-20

    thanks for your reply.
    AMD OpenCL SDK works well with the CPUs(E3-1230V2 ,Xeon X5650 ).

    intel_sdk_for_ocl_applications_2013_x64 was used, the sample codes from intel worked very well(cpu load > 95%) ,indicating that the CPUs were surpported by the SDK.

    Now the problem is that,on the same CPU(intel E3-1230V2 ,4 cores, 8 threads), my code can work with Intel OpenCL SDK,but only one core work well(cpu load < 30%).

     
    Last edit: ngagewj 2013-08-20
  • ngagewj

    ngagewj - 2013-08-20

    AMD-APP-SDK-v2.8 works well ,but AMD-APP-SDK-v2.8.1.0 cannot work.

     
  • Karl Rupp

    Karl Rupp - 2013-08-20

    Which operations do you use? Are these custom kernels, or ViennaCL-built-in kernels? What do you mean by 'AMD-APP-SDK-v2.8.1.0 cannot work'?

     
  • ngagewj

    ngagewj - 2013-08-21

    windows 7 x64 and windows server 2012 used, ViennaCL-built-in kernels,same problems .
    My program ,a program using GMRES(ViennaCL-built-in routine) to solve linear systems,builded in VS2010,if AMD-APP-SDK-v2.8 installed ,it worked;if AMD-APP-SDK-v2.8.1.0 installed ,it failed.

     
  • Karl Rupp

    Karl Rupp - 2013-08-21

    What is the error message? Is it 'device not found'? Is it something else?

     
  • ngagewj

    ngagewj - 2013-08-22

    CL device found,the device information:
    CL device vendor id:4098
    cl device name:xxxxx
    ....
    cl device max compute units:8
    cl device max work group size:1024
    cl device global mem size:2147483648
    cl device local mem size:32768

    error message:
    debug error!
    program:xxxxx.exe
    R6010
    -abort() has been called.
    (press retry to debug the application.)

     
  • Karl Rupp

    Karl Rupp - 2013-08-22

    Hmm, is it possible to get a stack trace?

     
  • ngagewj

    ngagewj - 2013-08-23

    Unhandled exception at 0x76994b32 in femcfdocl02.exe: Microsoft C++ exception: viennacl::ocl::build_program_failure at memory location 0x0046e538..

    err case CL_MAP_FAILURE: throw map_failure();

    call stack:

        KernelBase.dll!76994b32()   
    [Frames below may be incorrect and/or missing, no symbols loaded for KernelBase.dll]    
    KernelBase.dll!76994b32()   
    msvcr100d.dll!_CxxThrowException(void * pExceptionObject, const _s__ThrowInfo * pThrowInfo)  Line 157   C++
    

    femcfdocl02.exe!viennacl::ocl::error_checker<void>::raise_exception(int err) Line 531 C++
    femcfdocl02.exe!viennacl::ocl::error_checker<void>::checkError(int err, const std::basic_string<char,std::char_traits<char>,std::allocator<char> > & formal, const std::basic_string<char,std::char_traits<char>,std::allocator<char> > & formal, const std::basic_string<char,std::char_traits<char>,std::allocator<char> > & formal) Line 597 + 0x9 bytes C++
    femcfdocl02.exe!viennacl::ocl::context::add_program(const std::basic_string<char,std::char_traits<char>,std::allocator<char> > & source, const std::basic_string<char,std::char_traits<char>,std::allocator<char> > & prog_name) Line 297 + 0x44 bytes C++
    femcfdocl02.exe!viennacl::linalg::kernels::vector<float,1>::init() Line 126 C++
    femcfdocl02.exe!viennacl::linalg::opencl::av<float,float>(viennacl::vector_base<float,unsigned int,int=""> & vec1, const viennacl::vector_base<float,unsigned int,int=""> & vec2, const float & alpha, unsigned int len_alpha, bool reciprocal_alpha, bool flip_sign_alpha) Line 60 C++
    femcfdocl02.exe!viennacl::linalg::av<float,float>(viennacl::vector_base<float,unsigned int,int=""> & vec1, const viennacl::vector_base<float,unsigned int,int=""> & vec2, const float & alpha, unsigned int len_alpha, bool reciprocal_alpha, bool flip_sign_alpha) Line 61 + 0x1f bytes C++
    femcfdocl02.exe!viennacl::vector_base<float,unsigned int,int="">::operator=(const viennacl::vector_base<float,unsigned int,int=""> & vec) Line 393 + 0x22 bytes C++
    femcfdocl02.exe!viennacl::linalg::solve<viennacl::compressed_matrix<float,1>,viennacl::vector<float,1>,viennacl::linalg::no_precond>(const viennacl::compressed_matrix<float,1> & matrix, const viennacl::vector<float,1> & unx, const viennacl::vector<float,1> & rhs, const viennacl::linalg::gmres_tag & tag, const viennacl::linalg::no_precond & precond) Line 175 C++
    femcfdocl02.exe!viennacl::linalg::solve<viennacl::compressed_matrix<float,1>,viennacl::vector<float,1> >(const viennacl::compressed_matrix<float,1> & matrix, viennacl::vector<float,1> & unx, const viennacl::vector<float,1> & rhs, const viennacl::linalg::gmres_tag & tag) Line 344 + 0x28 bytes C++
    femcfdocl02.exe!OpenCLsolver() Line 134 + 0x28 bytes C++
    femcfdocl02.exe!solve() Line 1887 C++
    femcfdocl02.exe!main() Line 100 C++
    femcfdocl02.exe!
    tmainCRTStartup() Line 555 + 0x19 bytes C
    femcfdocl02.exe!mainCRTStartup() Line 371 C
    kernel32.dll!74ff850d()
    ntdll.dll!779dbf39()
    ntdll.dll!779dbf0c()

     
  • Karl Rupp

    Karl Rupp - 2013-08-28

    I upgraded my laptop to the same AMD-APP-SDK-v2.8.1.0 version (though on Linux rather than Windows) and did not get any errors. Can you confirm that the installation of the APP SDK itself is sane (by, for example, confirming that the samples in the SDK work)?

     
  • ngagewj

    ngagewj - 2013-09-07

    There was some problems with upgrade from AMD-APP-SDK-v2.8 to v2.8.1.0 on windows.
    I reinstalled windows and AMD-APP-SDK-v2.8.1.0 ,it worked.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks