#12 Gunship 2000 problem

closed
nobody
None
5
2002-03-28
2002-01-17
Anonymous
No

Just about every sound in Gunship 2000 is perfect
under VDMSound, except for one single digital sound
effect that can sometimes affect the enjoyment of the
game.

You'll probaly have to complete a mission in the game
to reproduce the problem.

When you achieve either primary or secondary
objectives in the game (e.g. by destroying specific
enemy targets), you receive radio confirmation from
HQ, this confirmation consists of a message at the
top of the display "Primary Achived", accompanied by
a digital sound effect that sounds a bit like white
noise.

The problem is that the digital sound effect is meant
to only last for a second or two (verified under real
DOS mode), but under VDMSound lingers throughout the
game in the form of a very loud buzzing or hissing
until you return to base, (typically 10-15 minutes).
During that time, the sound isn't right because of
this particular 'white noise' channel still switched
on.

It only seems like a small glitch in the otherwise
perfect digital sound and MIDI emulation of this game.

I include the following just in case it may be
relevant:

My hardware:
Athlon 1Ghz CPU, A-bit KT-7 RAID mobo, 256Mb SDRAM
Creative AudioPCI ES1371 sound card

My software:
Windows XP build 2600
VDMSound 2.0.4
Microsoft WDM sound card driver
(ES1371,ES1373 WDM) v5.1.2535.0 dated 01/07/2001
GUNSHIP 2000, final cd version, with add-on packs
included

Thanks in advance for any advice/help,

Ozrik

Discussion

  • Vlad ROMASCANU

    Vlad ROMASCANU - 2002-01-17
    • assigned_to: nobody --> vladr
     
  • Vlad ROMASCANU

    Vlad ROMASCANU - 2002-01-17

    Logged In: YES
    user_id=148964

    Hello,
    It may, indeed, be a FM emulation problem. How have you
    configured the game? Is there a place where I can download
    it or a demo? Could you provide me with a save-game (if
    applicable) just before the problem occurs?

     
  • Ben Kidlington

    Ben Kidlington - 2002-01-18

    Logged In: YES
    user_id=430487

    Hi,
    You can download Gunship 2000 from the following
    abandonware site.

    http://ganymede.spaceports.com/~cnv301/

    (Click on Software, then Simulations)

    To save you time, the exact URL of the game is,

    http://www.cnv301.themutual.net/dls/gs2000.zip

    I downloaded this and tested it, it looks like the same
    version that I originally bought.

    (Any problems let me know, and I'll send you my copy)

    To set it up, I first run SETUP.EXE, and select the
    following options.

    Sound Source: Sound Blaster
    Digitized Sound: On
    Music: All Music On
    Miscellaneous:
    Digital Sound Address: 220h
    Digital Sound IRQ: IRQ 5
    Digital Sound DRQ: DRQ 1

    I have also used values of 2 and 7 for Digital Sound IRQ,
    on different systems - same result.
    Likewise, I have used DRQ 2 - same result.

    After setting up, run the game by executing GS2000.COM.

    I could send you one of my savegames, but I don't think it
    would help. Unfortunately you can only save between
    missions, not during them. To reproduce the sound problem
    will require around ten minutes of gameplay. My advice, fly
    low and straight to the primary target in the easiest mode,
    probably training mode with enemy quility low, crashes
    turned off, etc. Destroy the targets there, the sound
    glitch will occur on the moment of confirmation from HQ
    that the targets have been destroyed. If you need any help
    or further advice on how to play the game, then I'll be
    glad to offer any help I can,
    Thanks for your time,
    Ozrik

     
  • Vlad ROMASCANU

    Vlad ROMASCANU - 2002-02-11

    Logged In: YES
    user_id=148964

    Replicated the problem with GS2000.
    It's an AdLib problem.

     
  • Vlad ROMASCANU

    Vlad ROMASCANU - 2002-02-11
    • assigned_to: vladr --> nobody
     
  • Ben Kidlington

    Ben Kidlington - 2002-02-12

    Logged In: YES
    user_id=430487

    I'm glad you could reproduce the problem.
    Cheers,
    Ozrik

     
  • Vlad ROMASCANU

    Vlad ROMASCANU - 2002-03-28

    Logged In: YES
    user_id=148964

    Fixed in unofficial v1.0.4.1 release (Ben, I sent it to you
    by e-mail at sourceforge.net).

    V.

     
  • Vlad ROMASCANU

    Vlad ROMASCANU - 2002-03-28
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks