Problem with mhmake and paths

  • David Lawler

    David Lawler - 2009-11-11


    I could not get mhmake to behave.  After a long time I tracked it down to having sed in C:\Program Files\Utils (along with gawk/awk and gzip).  The space in the path was the problem.  I 'fixed' it for now with what might be an ugly change to line 998 from:
    FullCommandLine+=g_QuoteString + QuoteFileName(tmpCommand) + Params + g_QuoteString;
    not really a C programmer….so this might be ugly or wrong…..but it worked.

    Two other issues….before and after the above change the small applications in the apps folder do not get compiled on my setup and then mhmake has a problem when it tries to copy the exe's.  I solved that bye going into each app's folder (xcalc, xclock and xwininfo) and executing mhmake in them after the main mhmake blew and then re-ran the main mhmake and it worked.  Lastly, in my setup I also ran into a problem where the debug version would not compile.  I get:

    C:\Documents and Settings\LD003\My Documents\Programming Projects\vcxsrv\xorg-server>mhmake MAKESERVER=1 DEBUG=1

    Building "c:\documents and settings\ld003\my documents\programming projects\vcxsrv\libx11\src\obj\servdebug\ks_tables.h"
    The system cannot execute the specified program.
    Error occured: Error running command: util\obj\servdebug\makekeys < ..\..\x11\keysymdef.h > obj\servdebug\ks_tables.h
    Command defined in makefile: "c:\documents and settings\ld003\my documents\programming projects\vcxsrv\libx11\src"

    Maybe another path issue?  I have not figured out this issue yet.

    Regards, David

  • marha

    marha - 2009-11-12

    I will have a look at the first issue.

    For the last issue, I already had checked in a fix in revision 248 (trunk\libx11\src\makefile). Are you using this fix?


  • marha

    marha - 2009-11-12

    The fix that you have suggested for the first problem is the correct one. I have committed this fix in revision 275.
    The reason I did not see this problem before, is that this problem does not occur when running mhmake from 4nt.exe. It only happens when running from cmd.exe.
    This fix also solves the last issue you reported for me. The fix I had checked in just made the spaces disappear in the command.



Log in to post a comment.