#1 Install instructions seem out of date

closed-fixed
5
2006-10-17
2006-06-13
Anonymous
No

I tried following the installation directions on the
web and in the file (they were identical). The
instructions did not work for me.

The file that I downloaded is vc-clearcase-1.82.el

;;;;; Installation:
;;
;; 1/ Put this file somewhere in your load-path and
byte-compile it.

Recived the following message:
** The function `untrace-function' is not known to be
defined.

;;
;; 2/ Open open vc-clearcase.el in Emacs, than execute
the code below.
;; This will create a file named vc-clearcase-auto.el
containing the
;; autoloads for the file.
;;
;; (with-current-buffer (get-buffer "vc-clearcase.el")
;; (let* ((file (buffer-file-name (current-buffer)))
;; (dir (file-name-directory file))
;; (generated-autoload-file
;; (expand-file-name "vc-clearcase-auto.el"
dir)))
;; (update-file-autoloads file)))
;;

Tried this as well using M-: to evaluate a lisp command
. I cut and pasted the above lisp expression(without
the ";;") to the minibuffer.

Debugger entered--Lisp error: (wrong-type-argument
stringp nil)
set-buffer(nil)
(save-current-buffer (set-buffer (get-buffer
"vc-clearcase.el")) (let* (... ... ...)
(update-file-autoloads file)))
(with-current-buffer (get-buffer "vc-clearcase.el")
(let* (... ... ...) (update-file-autoloads file)))
eval((with-current-buffer (get-buffer
"vc-clearcase.el") (let* (... ... ...)
(update-file-autoloads file))))
eval-expression((with-current-buffer (get-buffer
"vc-clearcase.el") (let* (... ... ...)
(update-file-autoloads file))) nil)
* call-interactively(eval-expression)

I am guessing that the buffer name needs to include the
revision number (i.e. (set-buffer (get-buffer
"vc-clearcase.el")) should indicate the name of the
actual buffer ... in this case "vc-clearcase-1.82.el"

;; 3/ Add the following line to your .emacs file:
;;
;; (load "vc-clearcase-auto")
;;
;; If you don't want to generate autoloads, you will
have to add the
;; symbol CLEARCASE to `vc-handled-backends' via
customize, to tell
;; the vc package about the new backend (the autoloads
above do that
;; automatically for you.)

I could not get the mode installed using your
instructions.
ian.perryman@cisco.com

Discussion

  • Nobody/Anonymous

    Logged In: NO

    I forgot to add that the version of emacs that I am using
    is 21.3.1 on RHEL.

    I don't know what the problem is with the byte compile, but
    the autoload feature seems to have been renamed in
    autoload.el to generate-file-autoloads (not
    generated-autoload-file as in the code example)

    I was able to get it going by creating the file manually and
    running he generate-file-autoloads from the command line and
    saving the results ine appropriate file.

    ian.perryman@cisco.com

     
  • Alex Harsanyi

    Alex Harsanyi - 2006-06-17

    Logged In: YES
    user_id=158922

    Thanks for the bug report.

    The downloaded file needs to be renamed back to vc-
    clearcase.el and Step 2 of the install instructions should
    work. The SourceForge release system caught me by
    surprise and I had to rename the file to vc-clearcase-
    1.82.el at the last moment (I will a tar.gz archive for
    the next release).

    The autoload generation was only tested on GNU Emacs 22
    (from CVS), for emacs 21 I simply do a (require 'vc-
    clearcase) in my ~/.emacs file.

    I will update the installation intructions on the web page
    and the source file w.r.t GNU Emacs 21 sometime next week
    (I'm currently at a public terminal in the Singapore
    airport :-)

    Alex.

     
  • Alex Harsanyi

    Alex Harsanyi - 2006-06-19
    • assigned_to: nobody --> haral
    • status: open --> open-accepted
     
  • Alex Harsanyi

    Alex Harsanyi - 2006-06-21

    Logged In: YES
    user_id=158922

    Based on feedback from ian.perryman@cisco.com, the follwing code will
    bytecompile and generate autoloads for Emacs 21:

    (save-window-excursion
    (require 'autoload)
    (with-current-buffer
    (or (get-buffer "vc-clearcase.el")
    (find-file
    (read-file-name "Find vc-clearcase.el: " nil nil
    'must-match)))
    (let* ((file (buffer-file-name (current-buffer)))
    (base (file-name-nondirectory file))
    (dir (file-name-directory file))
    (generated-autoload-file
    (expand-file-name "vc-clearcase-auto.el" dir)))
    (unless (equal base "vc-clearcase.el")
    (error "Expecting a file named vc-clearcase.el, got %s" base))
    ;; byte-compile-file returns nil if there were errors
    (unless (byte-compile-file file)
    (error
    "Failed to compile %s, check the *Compile-Log* buffer for
    errors"
    file))
    (with-current-buffer (find-file generated-autoload-file)
    (erase-buffer)
    (insert "\f")
    (generate-file-autoloads file)
    (save-buffer)))))

    The follwing does the same for Emacs22:

    (save-window-excursion
    (require 'autoload)
    (with-current-buffer
    (or (get-buffer "vc-clearcase.el")
    (find-file
    (read-file-name "Find vc-clearcase.el: " nil nil
    'must-match)))
    (let* ((file (buffer-file-name (current-buffer)))
    (base (file-name-nondirectory file))
    (dir (file-name-directory file))
    (generated-autoload-file
    (expand-file-name "vc-clearcase-auto.el" dir)))
    (unless (equal base "vc-clearcase.el")
    (error "Expecting a file named vc-clearcase.el, got %s" base))
    ;; byte-compile-file returns nil if there were errors
    (unless (byte-compile-file file)
    (error
    "Failed to compile %s, check the *Compile-Log* buffer for
    errors"
    file))
    ;; update-file-autoloads returns nil if no autoloads were found.
    (when (update-file-autoloads file 'save-after)
    (error "Failed to find autoloads in %s" file)))))

    To evaluate the lisp code, move the cursor at the end of it and type C-x
    C-e.

     
  • Alex Harsanyi

    Alex Harsanyi - 2006-08-21
    • status: open-accepted --> closed-accepted
     
  • Alex Harsanyi

    Alex Harsanyi - 2006-08-21

    Logged In: YES
    user_id=158922

    The latest version of the package comes with updated installation instructions in
    the file INSTALL. The web page no onger contains installation instructions.

    Closing issue.

     
  • Alex Harsanyi

    Alex Harsanyi - 2006-10-17
    • status: closed-accepted --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks