#32 Port to SFML 2.0

Added
closed
Linking (5)
7
2015-04-04
2013-04-18
No

SFML 2.0 is the default in Arch Linux. I have started porting vba-m to using it, but I only started learning C++ a few days ago, and I'm afraid this may be too much right now. Nevertheless, I have created a git repo where most (if not all) functions have been replaced with their new counterparts, assuming I got it right: https://github.com/Alucryd/vba-m-sfml2/tree/sfml2. It still won't build, I haven't changed any function argument since I don't undertand most of them yet.
Would it be much work for you to look into this?

Discussion

  • Squall Leonhart

    Squall Leonhart - 2013-04-19

    joybus linking wasn't our idea, so we haven't really the motivation to make the 2.0 version work.

     
  • Squall Leonhart

    Squall Leonhart - 2013-04-19

    though, since bgk has his own linking branch atm, maybe he would be best to see to it, since it affects some of the work he has done there.

     
  • Squall Leonhart

    Squall Leonhart - 2013-04-19
    • assigned_to: nobody --> bgk
    • priority: 5 --> 7
     
  • Bastien Bouclet

    Bastien Bouclet - 2013-04-20

    This will not be merged until SFML 2.0 is released. It was a mistake of ArchLinux to include it so soon.
    We may use your work later though. Thanks.

     
  • Maxime Gauduin

    Maxime Gauduin - 2013-04-21

    I understand, though I wouldn't go as far as to say using 2.0 RC in arch was a mistake, we just don't like old stuff.

     
  • Maxime Gauduin

    Maxime Gauduin - 2013-09-24

    Hi guys, just a small heads up about sfml: 2.1 final has been released some time ago. 2.0 is now available Fedora, while Arch Linux provides 2.1.

     
  • Squall Leonhart

    Squall Leonhart - 2013-09-24

    sfml is actually looking to be on a chopping block.

     
  • Maxime Gauduin

    Maxime Gauduin - 2013-09-24

    So it would seem, and I've had quite a few people who weren't satisfied with it (for instance the dolphin-emu dev in charge of that part of the code would very much like to use sth else). Getting rid of it here too sounds like a good idea. We still have no GBA emulator (well dedicated, there are still mednafen and higan) in our official Arch Linux repos and SFML 1.6 is the only thing keeping me from pushing vba-m-{gtk,wx} to our [community] repo. I and the other TUs as well are against pushing an outdated sfml1.6 dep for just 2 packages.

     
    Last edit: Maxime Gauduin 2013-09-24
  • Squall Leonhart

    Squall Leonhart - 2013-09-24

    which dolphin dev would that be, it was shuffle2 that introduced sfml to dolphin and vba-m in the first place.

     
  • skid

    skid - 2015-04-04

    Fixed by r1292.

     
  • skid

    skid - 2015-04-04
    • status: open --> closed
    • Group: --> Added
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks