The two errors I encounter are :

arch/um/os-Linux/process.c:142: error: expected declaration specifiers or '...' before 'getpid'

exist at least in 2.6.16.33 and fixed by your patch(I can't find it now...).

Another is fixed by http://lkml.org/lkml/2006/12/4/355 , which exists in 2.6.19.2 .

Now I upgraded host kernel to 2.6.20.3, but uml still can't work. Same error. I tried DSL-2.2 too, almost the same output as fc5.

I noticed the warning, but puzzled... Is there a version surely can be used now? I am planning to try hacking kernel using UML.

Another question: is my version of UML have something to do with this? It's seems like a version string of kernel ( 2.6.18-1um-2: i386 ).

Thanks.

--
regards,
Yang Sheng