Antoine
 
I had same issue before. using gdb 6.3 under x86_64 it was working okay. Then I jumped to gdb 6.5 under i686 and it worked fine only if I ran as user root. Now with gdb 6.8 I can not do that. It looks the gdb people has closed the door to debug setuid programs. So the suggestion is to allow the UML to boot normally and let it pass the networking and then re-attach via gdb.
 
David Rodriguez

On Tue, May 26, 2009 at 8:28 AM, Antoine Nguyen <antoine.nguyen@streamcore.com> wrote:
Hi all,

I'm using a recent kernel (2.6.29.2, compiled by myself) for debugging
purposes. When I launch the guest inside gdb, all is going well until
network configuration. At the moment uml_net is called, I see a
"Permission denied" error inside GDB, which does not appear when I
launch the guest normally.

Error inside GDB:
[New LWP 11721]
Executing new program: /proc/11721/exe
/proc/11721/exe: Permission denied.

Error inside the guest:
helper_wait : waitpid process 11721 failed, errno = 10
tuntap_open_tramp : didn't receive a message
setreuid to root failed : : Operation not permitted
tuntap_open_tramp failed - err = 22

I'm running ubuntu 8.04 server on the host. There is a uml_net group
defined and my user is registered inside. uml_net permissions are as
follow :

-rwsr-x--- 1 root uml-net 24792 2007-12-04 16:50 /usr/lib/uml/uml_net

Does someone has any idea about what is happening?

Thanks.

--
Antoine Nguyen
Ingénieur R&D
www.streamcore.com


------------------------------------------------------------------------------
Register Now for Creativity and Technology (CaT), June 3rd, NYC. CaT
is a gathering of tech-side developers & brand creativity professionals. Meet
the minds behind Google Creative Lab, Visual Complexity, Processing, &
iPhoneDevCamp asthey present alongside digital heavyweights like Barbarian
Group, R/GA, & Big Spaceship. http://www.creativitycat.com
_______________________________________________
User-mode-linux-user mailing list
User-mode-linux-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/user-mode-linux-user