I decided to post on a wider audience. So far the uml vmlinux  gets block on bootup at
page_ok(top) ->  n = *address;
when calculating the top of the address space.

So my only guess so far is that the RHEL 5.0 has the option:
enable and the Ubuntu does not.
If I change the top starting address from:
unsigned long top = 0xffffd000 >> UM_KERN_PAGE_SHIFT
unsigned long top = 0xf0000000 >> UM_KERN_PAGE_SHIFT
it works. 

Does anybody know why it would be?


David Rodriguez

On Wed, Feb 11, 2009 at 7:28 PM, David Francisco Rodriguez Perez <david.francisco.rodriguez@gmail.com> wrote:
Hi All

I downloaded linux 2.6.29-rc2 and I did applied a recent patch from Heiko Carstens (link below) to fix a link problem.


If I run in ubuntu 8.04 (libc 2.7) it runs okay. But If I run in RHEL 5.0 (libc2.5) it gets bock in:
$ ./vmlinux mem=128M
Locating the bottom of the address space ... 0x0
Locating the top of the address space ...

So it looks like a problem seen before like


But that patch is already in. So does anybody know why would it be happening?


David Rodriguez

PS. So far it stops at:

(gdb) n
31            n = *address;
(gdb) n