Hi Jeff

I was able to compile with our filesystem with the linux executable as initramfs and it runs. if I run just ./linux it does show
up to:

UML running in SKAS0 mode

and it does not print anything else. Although I noticed that it spawned only 1 process more. But If I run with ./linux mem=128M it does print all the way until:

Couldn't stat "root_fs" : err = 2
Failed to initialize ubd device 0 :Couldn't determine size of device's file
line_ioctl: tty0: unknown ioctl: 0x541e
Doing Startup...           <==my rcS
Finishing Startup         <==end of rcS
/bin/sh: can't open tty0 <=busybox.

and I see 4 process running. So it does run but I need to specify the memory size. Here the question is why?  I need to figure it out the console issue and who is doing the unknown iotcl(I think is busybox but I will have to investigate).


David Rodriguez

On Thu, Jun 5, 2008 at 2:10 PM, Jeff Dike <jdike@addtoit.com> wrote:
On Tue, Jun 03, 2008 at 10:16:00AM -0700, David Francisco Rodriguez Perez wrote:
> I wanted to know if I can boot a UML Linux executable that has the initramfs
> (initramfs_data.cpio.gz) image built in it? If so what would I need on the
> command line?

I don't think you need anything special.  I tried it, and the
initramfs seemed to run, but nothing printed, so I guess somehow it
had no console.  See the thread titled "UML and initramfs" on uml-user
starting on Feb 27.


Work email - jdike at linux dot intel dot com