Hi,
      Thsnks for the reply. Pls refer inline.
Regards,
Pranjal

 
On 5/22/06, Blaisorblade <blaisorblade@yahoo.it> wrote:
On Monday 22 May 2006 11:07, Pranjal Kumar Dutta wrote:
> Hi All,
>                 I have my host 2.6.15.6 kernel with skas patch and my guest
> kernel also in 2.6.15.6 that runs in skas mode. I have no problem in
> booting the UML kernel with root fileystems provided in uml website. And
> then in my UML kernel I can mount hostfs into my /mnt/host to access the
> data in my disk. But here I face a probelm when  try to runa program in my
> hostfs (e.gzebra routing suite). because my librariries(
> e.g libc.so.5) and other paths are now not mounted at / , rather at
> /mnt/host.

Try prepending in the shell LD_LIBRARY_PATH=/mnt/host/lib:/mnt/host/usr/lib
(add other paths as needed); be careful since this may cause crashes in
programs from UML root fs, since they can get libraries they don't expect
(and I've seen such crashes).
[Pranjal] : I have tried doing that once, but got some other errors. I will try setting the path once again and will let you know the result.
 
 

> So, I tried to boot the UML kernel directly from my hostfs
> itself and failed. I am not able to understand clearly the step given at
> uml website on booting directly from hostfs.
There are people which do it successfully, but try the other approach first.
About what to do, I don't know... if you have a little doubt ask it,
answering may be easier.
 
[Pranjal]OK, I will privde the steps that I tried to boot hostfileystem directly. Then it would be easier to point the problems.
 

> If anybody can provide me
> detailed info or can give pointers to useful info that would be of great
> help.

--
Inform me of my mistakes, so I can keep imitating Homer Simpson's "Doh!".
Paolo Giarrusso, aka Blaisorblade (Skype ID "PaoloGiarrusso", ICQ 215621894)
http://www.user-mode-linux.org/~blaisorblade




___________________________________
Yahoo! Messenger with Voice: chiama da PC a telefono a tariffe esclusive
http://it.messenger.yahoo.com