I tried to do it but still my uml is not connecting to the outside world. I did the following steps
First in the host I did the following,
ifconfig eth1 promisc up
brctl addbr uml-bridge
brctl setfd uml-bridge 0
brctl sethello uml-bridge
brctl stp uml-bridge off
ifconfig uml-bridge netmask up
tunctl -t tap0
ifconfig tap0 promisc up
brctl addif uml-bridge tap0

Then I got into the directory where I had the uml and gave the following option with uml boot command

Then in uml I gave eth0 its ip address using the command
ifconfig eth0 netmask

But when I tried to add the default gateway as by using the route add command, I get an error which just tells me that there is no such device. I think I am missing something. Can someone let me know what is it that I am missing.

After this I started

On 9/10/07, Jeff Dike <jdike@addtoit.com> wrote:
On Mon, Sep 10, 2007 at 02:53:44PM -0400, siddhu srivatsan wrote:
> Hi,
> I downloaded the Kernel and Filesystem and got UML functioning. However, I
> was wondering if we can connect UML to host eth1?
> If so is it just a replacement of eth0 with eth1 in the commands specified
> in the networking session or some different set of instructions need to be
> followed.

I think what you want is to create a tap device, give it to UML as its
eth0, and bridge it with the host's eth1.

The documentation I've written generally uses routing rather than
bridging - there are UML bridging HOWTOs around, so follow one of


Work email - jdike at linux dot intel dot com