Thanks Lars.

Actually i did more testing, without my app, i just start 20 UMLs all together, some xterms got killed.
So the problem is UML, not my app.

I left the error message in the company, but briefly the TAP devices have issues.
In my case, each UML has a static ip. When all 20 starts, you can easily see the error with stack trace.

Now if i run all these in a vm in a vmWare server, it's even easier to reproduce, everything seems to be slower.

So far this project turns out to be a mess and i'm praying they won't fire me.

> From:
> To:
> CC:
> Date: Fri, 23 Dec 2011 09:51:15 +0100
> Subject: RE: [uml-user] xterm got kill when i run application in uml, how come ?
> Hi,
> Use "-hold" option to xterm. The terminal window will stay open
> even when the executed program has terminated. But you will have
> to close all windows manually, which you might find very annoying
> considering the number of vm's.
> Regards,
> Lars Ekman
> -----Original Message-----
> From: ning ji []
> Sent: den 23 december 2011 03:15
> Cc:
> Subject: [uml-user] xterm got kill when i run application in uml, how come ?
> it's a little bit complicated,
> 1. i have a script starts 20 xterms like this,
> xterm -e "uml ..."
> so basically i run 20 umls in my pc, each in a xterm so i can check
> the progress.
> 2. each of uml will automatically start my application,
> which is multithreaded, has pipes, sockets etc.
> when i do this, every once a while some xterms disappear.
> if the UMLs don't run my app, i know it's fine.
> but if my app has bug, how can it kills the xterm ?
> During this procedure, i keep on checking pc memory by "free -m",
> and seems it has plenty of free memory.
> Total is ~3GB, but i never see the used memory exceed 2GB.
> Shared memory usage is only ~20%.
> thanks !