Yes it does not work to me either. I can use <&- butI can not do </dev/null. Then the vmlinux get stuck. My kernel is
Locating the bottom of the address space ... 0x1000
Locating the top of the address space ... 0xc0000000
Core dump limits :
        soft - 0
        hard - NONE
Checking that ptrace can change system call numbers...OK
Checking syscall emulation patch for ptrace...OK
Checking advanced syscall emulation patch for ptrace...OK
Checking for tmpfs mount on /dev/shm...OK
Checking PROT_EXEC mmap in /dev/shm/...OK
Checking for the skas3 patch in the host:
  - /proc/mm...not found: No such file or directory
  - PTRACE_FAULTINFO...not found
  - PTRACE_LDT...not found
UML running in SKAS0 mode
Adding 3125248 bytes to physical memory to account for exec-shield gap
[    4.790000] line_ioctl: tty0: unknown ioctl: 0x5600
And it is always at:
(gdb) bt
#0  0x0054c410 in __kernel_vsyscall ()
#1  0x001a1970 in __nanosleep_nocancel () from /lib/
#2  0x080774a1 in idle_sleep (nsecs=194379572) at /home/aapace/PERFORCE/7.1.1.R01-aapace-calabasas/engr/sw/tps/kernel/linux/arch/um/os-Linux/time.c:185
#3  0x08062e8f in default_idle () at /home/aapace/PERFORCE/7.1.1.R01-aapace-calabasas/engr/sw/tps/kernel/linux/arch/um/kernel/process.c:248
#4  0x08063386 in cpu_idle () at /home/aapace/PERFORCE/7.1.1.R01-aapace-calabasas/engr/sw/tps/kernel/linux/arch/um/kernel/process.c:256
#5  0x0830d8b7 in rest_init () at /home/aapace/PERFORCE/7.1.1.R01-aapace-calabasas/engr/sw/tps/kernel/linux/init/main.c:434
#6  0x080498ea in start_kernel () at /home/aapace/PERFORCE/7.1.1.R01-aapace-calabasas/engr/sw/tps/kernel/linux/init/main.c:684
#7  0x0804c37c in start_kernel_proc (unused=0x0) at /home/aapace/PERFORCE/7.1.1.R01-aapace-calabasas/engr/sw/tps/kernel/linux/arch/um/kernel/skas/process.c:46
#8  0x08075661 in run_kernel_thread (fn=0x804c350 <start_kernel_proc>, arg=0x0, jmp_ptr=0xb96889c) at /home/aapace/PERFORCE/7.1.1.R01-aapace-calabasas/engr/sw/tps/kernel/linux/arch/um/os-Linux/process.c:267
#9  0x08063142 in new_thread_handler () at /home/aapace/PERFORCE/7.1.1.R01-aapace-calabasas/engr/sw/tps/kernel/linux/arch/um/kernel/process.c:151
#10 0x00000000 in ?? ()
2010/11/25 Péter Szabó <>
> vmlinux ..... 0<&- >log_file 2>&1

I'm using kernel Try running it with vmlinux </dev/null
vmlinux <input_file  (no need to redirect stdout or stderr, it didn't
make a difference for me) or cat input_file | vmlinux . Neither of
which works for me, they produce the errors I've described in my
previous e-mail. Could you please confirm that the commands above work
for you?