Hi,
I was trying to make SELinux work on UML with 32 bit kernel 2.6.19.2.

I downloaded the latest kernel souce code from http://www.kernel.org/pub/linux/kernel/v2.6/

As, it is supposed to have both UML and SELinux within it.

I got the ".config" file from http://uml.nagafix.co.uk/kernels/kernel32-2.6.19.2.config

After compilation as per instructions from page http://uml.nagafix.co.uk/kernels/
When I ran this kernel, it stoped immediately  after printing "UML running in SKAS0 mode" without throwing any error message.

I got following as output when I ran UML kernel complied from 2.6.19.2

{{{
$ ./linux ubd0=FedoraCore5-x86-root_fs
Checking that ptrace can change system call numbers...OK
Checking syscall emulation patch for ptrace...OK
Checking advanced syscall emulation patch for ptrace...OK
Checking for tmpfs mount on /dev/shm...nothing mounted on /dev/shm
Checking PROT_EXEC mmap in /tmp/...OK
Checking for the skas3 patch in the host:
  - /proc/mm...not found
  - PTRACE_FAULTINFO...not found
  - PTRACE_LDT...not found
UML running in SKAS0 mode

$
}}}


I have also applied the vm non-standard split patch to the kernel, but still it behaves in same way.


I also downloaded the precompiled kernels from http://uml.nagafix.co.uk/kernels/ but they also gave same behaviour.

I am trying these experiments on Debian x86 machine with kernel 2.6.18

The filesystem used by me is from http://uml.nagafix.co.uk/FedoraCore5/FedoraCore5-x86-root_fs.bz2

Can I know what wrong steps I am doing ? Do I need to change the configuration file ?
or I need to have special file system to run SELinux on UML ?


Thank you
--
Pravin Shinde