Hi all,

A bit more debugging information.  Gdb shows that ./linux segfaults
at the same location in os_early_checks () at arch/um/os-Linux/start_up.c:264
no matter CONFIG_HOST_2G_2G is defined or not.  Any clue how to fix?
See my earlier email below for my kernel settings.  Thanks for your help.

Ken

# gdb ./linux
GNU gdb Red Hat Linux (6.3.0.0-1.63rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...Using host libthread_db library "/lib64/tls/libthread_db.so.1".

(gdb) run
Starting program: /root/linux-2.6.14.3/linux

Program received signal SIGSEGV, Segmentation fault.
_raw_spin_lock (lock=0x602bfb70) at include/asm/thread_info.h:47
47      {
(gdb) bt
#0  _raw_spin_lock (lock=0x602bfb70) at include/asm/thread_info.h:47
#1  0x000000006020de18 in _spin_lock_irqsave (lock=0x602bfb70)
    at kernel/spinlock.c:78
#2  0x000000006002d777 in vprintk (
    fmt=0x60234ee8 "Checking that ptrace can change system call numbers...",
    args=0x7fbffff470) at kernel/printk.c:540
#3  0x000000006002d730 in printk (fmt=Variable "fmt" is not available.
) at kernel/printk.c:516
#4  0x0000000060026989 in os_early_checks () at arch/um/os-Linux/start_up.c:264
#5  0x0000000060019e7f in linux_main (argc=1, argv=0x7fbffff908)
    at arch/um/kernel/um_arch.c:336
#6  0x0000000060012fda in main (argc=1, argv=0x7fbffff908, envp=0x7fbffff918)
    at arch/um/kernel/main.c:152


On 12/13/05, Karamazov Brothers <karamazov.brothers@gmail.com> wrote:
Hi all,

Puzzled and need some help.

I downloaded the stock linux-2.6.14.3.tar.bz2, and
tried to make ARCH=um on RedHat's Enterprise Linux 4 update 2.  And the output segfaults immediately.

My procedures are as follows:
1) cd linux-2.6.14.3
2) make menuconfig ARCH=um
    2a) enable CONFIG_HOST_2G_2G, or
    2b) disable CONFIG_HOST_2G_2G
    and accept all other defaults.
3) make linux ARCH=um
4) ./linux --> immediate segfault (for both config 2a and 2b)

My RHEL4 update 2 is running kernel-2.6.9-22.EL.

I tried many many other prebuilt binaries from various
sites.  Most of them fail.  What should I do to make it work?

Ken