i try to build OCFS2 cluster in UML.

i use ocfs2-tools-1.2.2 package to this project. i was setting like following in chapter 12 USER MODE LINUX book.

i use kernel 2.6.24 and 2.6.25 as sources kernel UML

1. start build OCFS2 as modules kernel,

    linux-2.6.24# make modules_install INSTALL_MOD_PATH=../rootfs

INSTALL crypto/crypto_hash.ko

INSTALL crypto/hmac.ko

INSTALL crypto/sha1_generic.ko

INSTALL drivers/block/nbd.ko

INSTALL drivers/net/dummy.ko

INSTALL drivers/net/ppp_generic.ko

INSTALL drivers/net/slhc.ko

INSTALL drivers/net/slip.ko

INSTALL fs/autofs/autofs.ko

INSTALL fs/autofs4/autofs4.ko

INSTALL fs/binfmt_misc.ko

INSTALL fs/configfs/configfs.ko

INSTALL fs/dlm/dlm.ko

INSTALL fs/gfs2/gfs2.ko

INSTALL fs/gfs2/locking/dlm/lock_dlm.ko

INSTALL fs/gfs2/locking/nolock/lock_nolock.ko

INSTALL fs/ocfs2/cluster/ocfs2_nodemanager.ko

INSTALL fs/ocfs2/dlm/ocfs2_dlm.ko

INSTALL fs/ocfs2/dlm/ocfs2_dlmfs.ko

INSTALL fs/ocfs2/ocfs2.ko

INSTALL net/sctp/sctp.ko

DEPMOD 2.6.24

    same process i build OCFS2 as modules kernel to source kernel 2.6.25.
    i run the 2 kernel UML like this
    ./linux ubd0=FestyFawn-i386-rootfs root=/dev/ubda eth0=tuntap,uml-conn0 mem=128M

    ./linux ubd0=../FestyFawn-i386-rootfs root=/dev/ubda eth0=tuntap,uml-conn1 mem=128M
2. configure ocfs2-tools-1.2.2 package in UML
    before i run this step, i was upgrade my root filesystem to Ubuntu 8.04 HardyHeron and then i configure ocfs2-tools-1.2.2 package
tools-1.2.2# ./configure
3. i start ocfs2-tools-1.2.2 package with load necessary modules. 
    root@none:/usr/local/ocfs2-tools-1.2.2#./vendor/common/o2cb.init load

  Loading module “configfs”: OK
  Mounting configfs filesystem at /sys/kernel/config: OK
  Loading module “ocfs2_nodemanager”: OK
  Loading module “ocfs2_dlm”: OK
  Loading module “ocfs2_dlmfs”: OK

  Mounting ocfs2_dlmfs filesystem at /dlm: OK

4. i copy file cluster.conf to /etc/ocfs2/.
    root@none:/usr/local/ocfs2-tools-1.2.2#cat /etc/ocfs/cluster.conf
            ip_port = 7777
            ip_address =
            number = 0
            name = node0
            cluster = ocfs2

            ip_port = 7777
            ip_address =
            number = 0
            name = node1
            cluster = ocfs2    

           node_count = 0
           name = ocfs2

5. i setting hostname and ip address to
    UML0# hostname node0
    UML1# hostname node1
    then i restart both UMLs
6. then i run command on host system to setup filesystem to shared device.
    host_system$ dd if=/dev/zero of=ocfs seek=$[ 100 * 1024 ] bs=1K count=1
    host_system# uml_mconsole dxhcF8 config ubdbc=ocfs 
    where dxhcF8 is umid
    in UML file /dev seen like this
          root@node0:# ls -l /dev/ubd*
           /ubda /ubdb /urandom

7. after all process above ,  i have  problem when i try to online OCFS2
    root@node0:/usr/local/ocfs2-tools-1.2.2#./vendor/common/o2cb.init online ocfs2
    Starting O2CB cluster ocfs2: Failed
    ./vendor/common/o2cb.init: line 629: o2cb_ctl: command not found
    Stopping O2CB cluster ocfs2: Failed
    ./vendor/common/o2cb.init: line 652: o2cb_ctl: command not found

i was check the file o2cb.init

what happen about that failed ?? maybe i was missing one step to finish setup OCFS2 in UML.

any one can give me advice and explain about failed to online OCFS2 cluster.