Hi everyone.

I tried two solutions:

1) Compiling a new guest kernel. I got several errors during compilations with some kernel sources. I managed to compile successfully some sources, but the images didn't work at the end. Not even in a 32 bit system. I guess I did something horribly wrong xD.

2) Installing a 64 bit Ubuntu 8.10 with the latest version of the kernel. It uses a 2.6.27-7 kernel. It worked fine since the very beginning. I used exactly the same guest kernel image and filesystem, that is, I changed nothing but the host kernel. So, despite the guest kernel being a bit old it seems to work fine.

Thanks so much for your help. I hope this helps other people with the same problem.

Best regards.


Gordon Russell wrote:
I would still get you to update the host kernels to something newer.
That way you are sure it is not a kernel version think. 64 bit support
is much better as the guest kernels get newer.


Case 1) Host: 32 bits (2.6.24). Guest, UML Kernel: 32 bits.
Case 2) Host: 64 bits (2.6.24, 2.6.16). Guest: 32 bits. (the same

In both cases the host kernel is not too old (at least in the case of

This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
User-mode-linux-user mailing list