Hi,
     I am a beginner to user mode linux and I have downloaded the kernel and root file system from user mode linux website as mentioned below
 
kernel 2.6.16 and FedoraCore5-x86-root_fs
http://user-mode-linux.sourceforge.net/new/index.html 
 
I have tested this on Fedora 2.6.15-1.2054_FC5 ( kernel ) host machine and SUSE linux 10.0 host. Everything works fine and I am able see how UML works.
 
After that I have tried the below experiment
 
 build ucLibc (with busybox ) root filesystem using buildroot ( latest by default build image using 2.4.31 kernel headers) 
and used the above mentioned 2.6.16 uml kernel  to run UML.
 
Note: command   $./linux-2.6.16  ubda=rootfs.i686.ext2
 
Before run the UML command I have made modifications to etc/inittab, etc/fstab and etc/mtab as some UML document suggestions.
 
When I run the new experiment I am getting following error message and kernel crash
 
***Kernel panic - not syncing : No init found. Try passing init=option to kernel***
 
I have passed the option init=/sbin/init also and I still see the same error.
 
Can somebody suggest what I am doing wrong?  and
 
What all need to be taken care when building root file system for UML?
 
I want to build my own UML kernel and root filesystem. Is there any website to walkthrough?
 
Thanks in advance.
Sreeni.