Hi:
    I'm really amazed by how to insmod my owen module with UML
    Now, I'm doing kernel programming about how to improve buddy=20
    Using UML-path-2.6.9-bb4 rootfs=3Droot_fs.fc2-pritstine-client
    So, the version about gcc, insmod-tools, make were the same!
    But, when I make the kernel(in 2.6.9) module ok in my  host
       also can insmod *.ko normally=20
(insmod buddy_frq.ko)
    copy it to uml , then failed ,  such error message :

buddy_frq: version magic '2.6.9 PENTIUMII REGPARM gcc-3.3' should be
'2.6=
.9-bb4 gcc-3.3' insmod: error inserting 'buddy_frq.ko': -1 Invalid
module=
format=20

   could you help me? thanks
   best wishes
                                                                  
friend=
s: movie



Do You Yahoo!?
注册世界一流品质的雅虎免费电邮