Debian 3.0r0 root_fs superblock error.

Help
2003-10-02
2003-11-29
  • George P Boutwell

    I'm using SID, and the UML that's available as an package there.  I've
    d/led several root_fses.  Most of them generate an error about the
    processor not supporting cmov.  I finally broke down and tried the
    Debian 3.0r0 root_fs.  It boots, but everytime it boots it complains
    about the superblock and puts me in ro mode.  I've fixed it and mounted
    rw, but then when I boot again next-time I have to go through the
    process all over again.

    Any ideas?  Help?  It's not an file permission error, the files are not
    ro AND I've tried setting all rights and still get the same problem.

    Thanks,

    George

     
    • Anonymous - 2003-11-29

      The fstab tries to mount /dev/ubd/0 as root but the kernel is setting the root to be /dev/ubd0. Just mount it loopback or boot it normally, modify the fstab, and you should be all good. This is what worked for me, I'm not sure if you're having the same problem.

      Michael

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks