Riccardo - 2005-06-15

I'm using Ubuntu Hoary with kernel 2.6.10-5-i386

This is what I do for install:
- download from ubuntu's repository the package "linux-source-2.6.10"
- I insert tar.bz2 souce file in a new directory called /usr/src/uml
- Untar with "tar -xvjf"
- enter in the dir with the source and digit
make mrproper ARCH=um
make xconfig ARCH=um
make modules ARCH=um
- at this point download "uml-utilities"
- and test.

For testing I downloaded from the official uml site Debian-3.0r0

To launch I used:
/vmlinux ubd0=PERCORSO_FS

But uml exit with this error:
"Initializing Cryptographic API
sleeping process XXXX got unexpected signal : 11

actually_do_remove : couldn't open directory '/root/.uml/AbJ9iL', errno = 2
actually_do_remove : couldn't open directory '/root/.uml/AbJ9iL', errno = 2
Kernel panic - not syncing: Segfault with no mm"
OR :
"Initializing stdio console driver
sleeping process XXXX got unexpected signal : 11

actually_do_remove : couldn't open directory '/root/.uml/6nKFvh', errno = 2
actually_do_remove : couldn't open directory '/root/.uml/6nKFvh', errno = 2
Kernel panic - not syncing: Segfault with no mm"

Thinking that I have missed some setting in the compile step on 2.6.x kernel I followed this how-to:

http://uml.harlowhill.com/index.php/Troubleshooting
Using this settings the error is different:

"VFS: Cannot open root device "devicename" or unknown-block(x,y) Please append a correct "root=" boot option"

I tried to append root=/dev/ubd0 or /dev/ubd/0 or /dev/ubda
without better results

Someone can give me a hand ?