MrJackV - 2012-05-18

Hello, I am corrently trying to install usb/ip on an old mac G4 (using ubuntu with "kernel 2.6.38-15-powerpc-smp"), however I am a bit confused on how to correctly compile the modules for the kernel. I already tried to compile it with the KSOURCE set to "/usr/src/linux-headers-2.6.38-15-powerpc-smp", however the compile halts telling me that I need to run "make oldconfig && make prepare" in the header directory. However upon doing so the programs gives an error about being no rule for "kernel/bounds.c" . I have also done some research on the driver staging but I do not understand what I am supposed to do. I tried running "modprobe -list | grep staging" but no usbip-related module showed up. Moreover I tried downloading the driver staging tree from the address "git://", however I do not understand if that would be needed to be set as the new KSOURCE. The userland files compilation went fine but I am really struggling with the kernel modules. What do I have to do? Is there a solution to this problem?

Thanks in advance.