USARSim vehicles won't activate triggers

Help
Marin
2011-12-21
2013-05-06
  • Marin

    Marin - 2011-12-21

    Hi all,

    I need your assistance in USARSim. I'm doing on some project called "3D simulation of robotic warehouse".
    The problem is that robot Kiva4wheel does not activate my trigger on elevator and i don't know why.

    Here is the brief description of how did i make an elevator so maybe you will find out what seems to be the problem.
    I added some static mesh from Content Browser (S_HU_Deco_SM_Metalbase01), then right clicked on it, added InterpActor HU_Deco.SM.Mesh.S_HU_Deco_SM_Metalbase01 and deleted the old static mesh (i know i could simply convert it). Then i opened the properties of my platform and under Collision changed Collision Type to COLLIDE_BlockAll.

    After positioning the platform for my elevator, i added trigger on it (right click -> Add actor -> Add trigger) and moved trigger to the middle of my platform expanding the trigger area for a bit. Then i clicked on the trigger, opened UnrealKismet and added Matinee (right click -> add matinee) along with touch-type trigger (right click -> new event using trigger_1 -> Used). I connected "Touched" on "Trigger_1 Touch" with "Play" on "Matinee" and opened UnrealMatinee to adjust the movement of my platform.

    In UnrealMatinee i added a new empty group called "Elev" and then right clicked on that group to add new movement track. After adding the track for my elevator i could see that my elevator is working properly. When i tried to play from that spot, my pawn could walk on elevator and it would lift me up. After that, I changed the properties of trigger (clicking on trigger -> F4) like it was said on USARSim wiki FAQ (http://usarsim.sourceforge.net/wiki/index.php).

    The problem is when my team tried to do the same thing with Kiva4wheels robot. Kiva would step on that elevator but nothing happened. It was like the trigger was not activated by Kiva. We spawned Kiva on map with Matlab and Iridium but the results were same, the elevator was not moving at all. What have i done wrong?

    P.S.  UDK-2011-10 version

     
  • Jaime

    Jaime - 2013-05-06

    Hi Marin,

    I have the same problem with triggers and I would Like to know if you have found a solution.

     

Log in to post a comment.