#16 UnRarX incompatible with Mac OS X 10.2.8

open
nobody
None
5
2006-07-11
2006-07-11
Anonymous
No

As is common (but not the rule) with Universal Binary revisions, UnRAR
2.2 will not run on Mac OS X 10.2.8, and presumably anything below
that version.

My test setup: PowerBook Wall Street, G4 500 MHz, 512 MB RAM, Mac
OS X 10.2.8.

Presumably a recompile from the source code with the pre-universal
compiler will solve this problem. A second, backwards compatible
version will be very appreciated. This has been the approach of several
developers.

Crash note from the Console:

dyld: /Users/[user]/Desktop/UnRarX.app/Contents/MacOS/UnRarX
can't open library: /usr/lib/libmx.A.dylib (No such file or directory,
errno = 2)
Jul 11 09:05:07 [users]-Computer crashdump: Crash report written to:
/Users/[user]/Library/Logs/CrashReporter/UnRarX.crash.log

From CrashReporter:

**********

Date/Time: 2006-07-11 09:01:21 -0400
OS Version: 10.2.8 (Build 6R73)
Host: [users]-Computer.local.

Command: UnRarX
PID: 652

Exception: EXC_BREAKPOINT (0x0006)
Code[0]: 0x00000001Code[1]: 0x8fe01220

Thread 0 Crashed:
#0 0x8fe01220 in halt
#1 0x8fe0323c in load_library_image
#2 0x8fe060d4 in load_images_libraries
#3 0x8fe02688 in load_executable_image
#4 0x8fe013b0 in _dyld_init

PPC Thread State:
srr0: 0x8fe01220 srr1: 0x0002f030 vrsave: 0x00000000
xer: 0x20000000 lr: 0x8fe0a004 ctr: 0x8fe28ebc mq:
0x00000000
r0: 0x00000004 r1: 0xbffffb90 r2: 0x2800828c r3:
0x00000095
r4: 0x00000000 r5: 0x00000095 r6: 0x0000290a r7:
0x726e6f20
r8: 0x66696c65 r9: 0x00000000 r10: 0xbffff90b r11:
0x00000026
r12: 0x8fe71abd r13: 0x00000000 r14: 0x00002338 r15:
0x00000000
r16: 0xbffffe34 r17: 0x00000001 r18: 0x00000000 r19:
0x00001b08
r20: 0x00000000 r21: 0x00000000 r22: 0x00000000 r23:
0x00000000
r24: 0x8fe4b3d4 r25: 0x00000002 r26: 0x00000002 r27:
0x00000000
r28: 0x00001a54 r29: 0x00000000 r30: 0x8fe484d8 r31:
0x8fe09e6c

Discussion

  • Nobody/Anonymous

    Logged In: NO

    xxxx

     
  • Nobody/Anonymous

    Logged In: NO

    I am going to say the same thing. This does not run on my Mac OS 10.3.3, and I heard that there is a way to use GCC 3.3 for PPC and GCC 4.0 for Intel in the same application. My idea? Look up online what to do to compile a Universal Binary that works on a version earlier than Mac OS 10.3.9.

    Either fix this, or post a version for users earlier than Mac OS 10.3.9.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks