David Carter - 2005-02-09

I want my VIA 3D to work...getting closer, can almost smell it.

I have the Via ME6000 board and I still can't get it to work with 3D.  I followed the directions in the HowTo at:


I did not do the XvMC library portion  since all I want is 3D acceleration.  Now I have it all built and installed and my Xorg.0.log shows no errors and the following:

(II) VIA(0): [DRI] installation complete
(II) VIA(0): [dri] kernel data initialized.
(II) VIA(0): [drm] Irq handler installed, using IRQ 11.
(II) VIA(0): direct rendering enabled
Fulfilled via DRI at 5242880
(II) VIA(0): Benchmarking video copy. Less is better.
(--) VIA(0): Timed   libc YUV420 copy... 14592972. Throughput: 16.3 MiB/s.
(--) VIA(0): Timed kernel YUV420 copy... 11958069. Throughput: 19.9 MiB/s.
(--) VIA(0): Ditch    SSE YUV420 copy... Not supported by CPU.
(--) VIA(0): Timed    MMX YUV420 copy... 7344441. Throughput: 32.3 MiB/s.
(--) VIA(0): Timed 3DNow! YUV420 copy... 8381042. Throughput: 28.3 MiB/s.
(--) VIA(0): Ditch   MMX2 YUV420 copy... Not supported by CPU.
Freed 5242880 (pool 2)
(--) VIA(0): Using MMX YUV42X copy for video.
(WW) VIA(0): [XvMC] Kernel drm is not compatible with XvMC.
(WW) VIA(0): [XvMC] Kernel drm version: 1.3.0 and need at least version 2.4.0.
(WW) VIA(0): [XvMC] Please update. Disabling XvMC.
(WW) VIA(0): Option "CalcAlgorithm" is not used
(II) VIA(0): - Done

If I run glxinfo, it reports no direct rendering. I i run 3Ddiag, it also reports 'No 3D capable graphic chipset found. I don't care about XvMC so I can ignore the Disabling XvMC message...right?

I did not rebuild the kernel after I built the XFree86 4.4 baseline with Unichrome R30 package installed. I did the verify the  via_drv.o file date is correct in the /usr/X11R6/lib/modules/drivers directory. I'm running the stardard kernel that SuSe 9.2 ships with, 2.6..8-24-default.

Something did happen and I'm pretty sure I'm using the correct drivers because my glxgears frame rate was 50-60fps prior to the upgrade, and is now about 25fps...yep it went down.

I see from the ViaArena web site that there is a VIA kernel patch as well.    I would rather not mix another variable in until I get the 3D working correctly. Do I need that patch to get 3D working on my CLE266?

What am I missing here???

Dave Carter