E160 Problems

Jim George
2009-01-08
2013-04-15
  • Jim George

    Jim George - 2009-01-08

    Hi folks,

    I'm having problems getting my E160 to work and would appreciate some help to use, what appears to be the ideal application.

    Background:
    I'm using the above E160 on O2 PayandGo
    I'm using Xandros on an eeePC
    I'm using usb_modeswitch to ensure that it's seen as a modem (which it is).

    Symptoms/Anomalies:
    When I run umtsmon (from my home directory) as a normal user, even after setting the groups and ensuring pppd is setuid, umtsmon settings check doesn't show pppd version.  If I run it as root, it does find it.

    When I try to connect I get the following stderr message for pppd (when running as root):
    /usr/sbin/pppd: The remote system is required to Authenticate itself
    /usr/sbin/pppd: But I couldn't find any suitable secret (password) for it to use to do so.
    /usr/sbin/pppd: (None of the available passwords would let it use an IP address)

    Can someone guide me or tell me what to look at next?
    For information the modem works on my wife's Windows eeePc.

    Thanks in advance,

    Jim

     
    • Eugene Korotkov

      Eugene Korotkov - 2009-07-19

      i always got this message when i already have default route.
      you just need to try delete default gateway settings in you OS or delete it manually in console:
      sudo route del default gw 0.0.0.0

      as next step you can see pppd log file in /var/log/messages

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks