Can't compile UMTSmon on my 64bit machine

vusko
2008-08-09
2013-04-15
  • vusko

    vusko - 2008-08-09

    On my lenovo (64 bit computer, running kubuntu Hardy) I tryed to install the program. As it is written in the INSTALL file, I untar the pack, then Qmake the umtsmon.pro, but troubles came when I typed make clean all. The bash throwed to me two screens of errors like:

    .ui/mainwindow.h:12.22: error: qvariant.h: No such file or directory
    (and similar, and at the end: )
    make: *** [.obj/main.o] Error 1

    I guess is something wrong with my compiler (qt3?)? Can you please help me to fix this or has anybody any idea what is wrong?

    Thanks a lot!

     
    • Klaas van Gend

      Klaas van Gend - 2008-08-11

      QT3 is not a compiler, it is a library that is needed for umtsmon.
      a Library is a file that contains all kinds of functionality so I don't need to rewrite that for my application. As such, libraries usually come in handy - they save time.
      In the case of QT (pronounce "cute"), we're talking about a GUI library - for writing user interfaces.

      I suggest that you type:   'qmake --version' at a command prompt.
      That might already answer your problem - I guess you tried to compile against QT4. Umtsmon is definitively not compatible with QT4.  In this case, if you have installed qt3 development packages, I guess that the qmake for QT3 is located in e.g. /usr/lib/qt3/bin/qmake or something similar.
      Once you've run that qmake, the rest should compile flawlessly.

      If not, please post your complete logs, so I can actually try to understand what's going wrong. The above log was rather unusable short.

       
    • Celine

      Celine - 2008-08-21

      Hi,

      I had the same problem and solved it with apt-get install libqt3-mt-dev (and qmake from qt3-dev-tools).

       
    • Robert

      Robert - 2009-03-23

      i have a compile problem with qmake- i typed the full path qmake-qt4 /usr/share/qt3/bin/qmake

      but got the error qmake:1:parse error (`ELF

      i am using debian lenny amd64, and i really need a program to utilise my huawei E169G usb modem

       
      • Klaas van Gend

        Klaas van Gend - 2009-03-23

        Your message is a bit confusing - please elaborate:

        * don't use qmake for QT4 - we need the qmake for QT3.
           please post the output of your "/path/to/qmake --version" to make sure we're running the right one.
        * please post full compilation logs, preferably starting by extracting the tar archive
           to a clean directory. The error I see looks very very ugly - but it is not complete :-(
           do you have 32-bit support installed on your system?

        Klaas

         
      • Robert

        Robert - 2009-03-23

        I do appologise for my ignorance, i have not been using Debian for long, I have managed to get qmake working with the correct command, but now get a different error-

        error= QDir::currentdirpath:getcwd () failed (it says this three times)

        then says= cannot find directory.

         
        • Klaas van Gend

          Klaas van Gend - 2009-03-23

          Sorry, I cannot help you here - you provided waaay too little information.
          Don't filter for me - as is showcased here (twice already), you don't do a good job at that.
          Please provide full logs.

           
  • seg

    seg - 2009-09-22

    Hi,
    I also have problems compiling umtsmon
    I use an OSX 10.6.1
    I have installed xcode, Macports and the Ports libusb an qt3
    After the qmake I get the first warning:
    Failure to find: src/view/aboutdialog.ui

    The  "make clean all" terminates with:

    /bin/uic src/view/newprofiledialog.ui -o .ui/newprofiledialog.h
    make: /bin/uic: Permission denied
    make: ***  Error 1

    Can someone give me a hint how to compile this tool correct???

    Thanks

    Simon

     
  • David Maroshi

    David Maroshi - 2010-10-16

    Hello Team,

    I built UMTSmon for RHEL 6  x64

    I had a compilation error:
    src/base/SerialPort.cpp:89: error: ‘fstat’ was not declared in this scope
    src/base/SerialPort.cpp:95: error: ‘S_ISCHR’ was not declared in this scope

    I fixed the error by fixing the code:
    in file SerialPort.cpp added
    #include <sys/stat.h>
    In line 29

    Please take care to add this fix to the source
    Good luck

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks