#11 linux2.6.0test8-1um on linux2.6.0test8

v1.0_(example)
open
nobody
5
2003-10-24
2003-10-24
No

umlbuilder version: 1.50-3
host system: redhat9
host kernel: linux-2.6.0test8
UM kernel: linux 2.6.0test8-um (with modules)
I've managed to get umlbuilder to install redhat9 to the point where it
tries to launch the virtual machine. But it fails like this:

[andrew@andrew uml]$ umlbuilder --rpmdir /mnt/gwshared/rh9r
--dir /home/andrew/uml/rh9 --distro Redhat9.0 --hostname
server0.gmp --ipaddr 192.168.1.150 --rootpw root
Indexing RPMS
========================================|100%
Done.
Successful
Calculating packages, dependencies and install order
========================================|100%
Done.
Successful
Working in /home/andrew/uml/rh9
Making directories
Making files
Setting up swapspace version 1, size = 134213 kB
Populating install filesystem
========================================|100%
Done.
Successful
Running install process
tracing thread pid = 11693
Linux version 2.6.0-test8-1um (andrew@andrew.gmp) (gcc version
3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #2 Fri Oct 24 11:19:44
EEST 2003
On node 0 totalpages: 16384
DMA zone: 16384 pages, LIFO batch:4
Normal zone: 0 pages, LIFO batch:1
HighMem zone: 0 pages, LIFO batch:1
Building zonelist for node : 0
Kernel command line: rw umid=rh9 ubd0=rootfs mem=64m
ubd7=installfs rootflags=installfs eth0=tuntap,,,192.168.1.30
root=/dev/root rootfstype=hostfs init=/uml_stage2install.py
con0=pts,fd:1
PID hash table entries: 16 (order 4: 128 bytes)
Memory: 62224k available
Calibrating delay loop... 2057.83 BogoMIPS
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Checking for host processor cmov support...Yes
Checking for host processor xmm support...No
Checking that ptrace can change system call numbers...OK
Checking that host ptys support output SIGIO...Yes
Checking that host ptys support SIGIO on close...No, enabling
workaround
POSIX conformance testing by UNIFIX
NET: Registered protocol family 16
Initializing software serial port version 1
mconsole (version 2) initialized on /home/andrew/.uml/rh9/mconsole
Initializing stdio console driver
Virtual console 0 assigned device '/dev/pts/16'
Netdevice 0 : TUN/TAP backend - IP = 192.168.1.30
VFS: Disk quotas dquot_6.5.1
devfs: v1.22 (20021013) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
pty: 256 Unix98 ptys configured
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024
blocksize
loop: loaded (max 8 devices)
Using anticipatory io scheduler
nbd: registered device at major 43
Universal TUN/TAP device driver 1.5 (C)1999-2002 Maxim
Krasnyansky
NET: Registered protocol family 2
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 4096 bind 8192)
NET: Registered protocol family 1
NET: Registered protocol family 17
/dev/ubd/disc0: unknown partition table
VFS: Cannot open root device "root" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)

Install failed
result of system is 256
Installation failed.
[andrew@andrew uml]$

Any suggestions?

Discussion

  • Anonymous - 2003-10-30

    Logged In: YES
    user_id=30737

    Do you have hostfs compiled in (not as a module?)

    I haven't had a chance to try -test8 myself yet.

     
  • Ignacio Tripodi

    Ignacio Tripodi - 2004-01-25

    Logged In: YES
    user_id=959859

    Hi, I'm having a very similar problem with a 2.4.23 kernel trying
    to do a RedHat 8 install.

    I'm running the builder as follows:

    umlbuilder --ipaddr=10.1.1.251 --hostname=umlLinux.mydomain
    --initrd --swapsize=128 \ --fstype=ext2 --fssize=1900 --hostiface=eth0 --memsize=128 \ --dir=/temp --rpmdir=/mirror/ftp/pub/redhat/redhat-8.0patched-
    en/os/i386/RedHat/RPMS \ --modules admin-tools,base,core,development-
    libraries,development-tools,editors,ftp-server,gnome-software-
    development,kde-software-development,kernel-
    development,legacy-software-development,network-
    server,server-cfg,system-tools,text-internet,web-server,x-
    software-development \ --distro=Redhat8.0

    ... an this is the error message I get:

    Indexing RPMS
    ========================================|
    100% Done.
    Successful
    Calculating packages, dependencies and install order
    ========================================|
    100% Done.
    Successful
    Working in /lscratch/umlSELinux
    Making directories
    Making files
    Setting up swapspace version 1, size = 131068 KiB
    Populating install filesystem
    ========================================|
    100% Done.
    Successful
    Running install process
    Checking for the skas3 patch in the host...not found
    Checking for /proc/mm...not found
    tracing thread pid = 22880
    Linux version 2.4.23 (root@nigel.cops.private) (gcc version
    3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #3 Thu Jan 22 19:58:03
    CST 2004
    On node 0 totalpages: 16384
    zone(0): 16384 pages.
    zone(1): 0 pages.
    zone(2): 0 pages.
    Kernel command line: rw umid=umlSELinux ubd0=rootfs root=/
    dev/ubd0 mem=64m ubd7=installfs eth0=tuntap,,,10.1.1.4 root=/
    dev/ubd7 init=/uml_stage2install.py con0=pts,fd:1
    Calibrating delay loop... 2678.88 BogoMIPS
    Memory: 60528k available
    Dentry cache hash table entries: 8192 (order: 4, 65536 bytes)
    Inode cache hash table entries: 4096 (order: 3, 32768 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
    Page-cache hash table entries: 16384 (order: 4, 65536 bytes)
    Checking for host processor cmov support...Yes
    Checking for host processor xmm support...No
    Checking that ptrace can change system call numbers...OK
    Checking that host ptys support output SIGIO...Yes
    Checking that host ptys support SIGIO on close...No, enabling
    workaround
    Checking for /dev/anon on the host...Not available (open failed
    with errno 2)
    POSIX conformance testing by UNIFIX
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    VFS: Disk quotas vdquot_6.5.1
    Journalled Block Device driver loaded
    devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
    devfs: boot_options: 0x1
    Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
    JFFS version 1.0, (C) 1999, 2000 Axis Communications AB
    JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis
    Communications AB.
    pty: 256 Unix98 ptys configured
    SLIP: version 0.8.4-NET3.019-NEWTTY (dynamic channels,
    max=256).
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024
    blocksize
    loop: loaded (max 8 devices)
    PPP generic driver version 2.4.2
    Universal TUN/TAP device driver 1.5 (C)1999-2002 Maxim
    Krasnyansky
    SCSI subsystem driver Revision: 1.00
    scsi0 : scsi_debug, Version: 0.61 (20020815), num_devs=1,
    dev_size_mb=8, opts=0x0
    Vendor: Linux Model: scsi_debug Rev: 0004
    Type: Direct-Access ANSI SCSI revision: 03
    blkmtd: error: missing `device' name

    Initializing software serial port version 1
    mconsole (version 2) initialized on /root/.uml/umlSELinux/
    mconsole
    Partition check:
    ubda: unknown partition table
    unable to open installfs for validation
    ubd : Synchronous mode
    UML Audio Relay (host dsp = /dev/sound/dsp, host mixer = /dev/
    sound/mixer)
    Initializing stdio console driver
    Virtual console 0 assigned device '/dev/pts/2'
    Netdevice 0 : TUN/TAP backend - IP = 10.1.1.4
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 4096 bind 8192)
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    VFS: Cannot open root device "ubd7" or 62:70
    Please append a correct "root=" boot option
    Kernel panic: VFS: Unable to mount root fs on 62:70

    Install failed
    result of system is 256
    Installation failed.

    Any suggestions? Do you recommend trying with a 2.6.x kernel
    instead

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks