Version 1.13 on Freebsd 6.2

Help
Mike
2007-09-27
2013-05-20
  • Mike

    Mike - 2007-09-27

    The make fails due to PF_INET' undeclared

    ufdblib.c: In function `UFDBopenSocket':
    ufdblib.c:775: error: `PF_INET' undeclared (first use in this function)
    ufdblib.c:775: error: (Each undeclared identifier is reported only once
    ufdblib.c:775: error: for each function it appears in.)
    *** Error code 1

    The PF_INET is defined in sys/socket.h but for some reason does not work??

    I changed all the PF_ to AF_ and the make and install worked fine.
    Of course maybe not the software since the change may have some unknown effect ?
    The PF_INET looks as if defined the same as AF_INET in socket.h

    Thanks. Mike

     
    • Mike

      Mike - 2007-10-10

        Of course it would appear that changing the PF_ to AF_ in the code does break the ability of the daemon to listen on a socket as the daemon runs but the ufdb client cannot connect to it and the daemon does not show up on a sockstat command.
        However according to this there should be no difference between PF and AF and that AF is preferred.

      http://www.developerweb.net/forum/showpost.php?p=17391&postcount=5

       
    • ufdbGuard project admin

      It appear that the version 1.13 is missing an include file to define PF_UNIX on FreeBSD.
      The include file is not necessary on other OSes so the problem only appears here.

      version 1.14 will be out soon which includes a fix for the missing include file.

       
    • Mike

      Mike - 2007-10-10

      Needs a change permissions on the /tmp/ufdbguardd-03977 if you run ufdbguard as root as the squid process cannot access the socket as file permissions are set as
      srwxr-xr-x   1 root    wheel          0 Oct 10 10:12 ufdbguardd-03977

      change to
      srwxrwxrwx ufdbguardd-03977

      and now it works.....

       
    • ufdbGuard project admin

      Version 1.14 includes a fix for this.
      v1.14 beta is available upon request.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks