Library Dependencies

TJ Apple
2011-03-21
2013-05-28
  • TJ Apple

    TJ Apple - 2011-03-21

    I'm hoping someone can give me the missing link (no pun intended) I need.

    I've built the U3D libraries along with all the other demo software (using PC on XP with VS2003 C++) everything runs no problem.

    However, in developing my own code, I've followed the U3D steps taken in HelloWorld, dropped out parts I don't need (animation being one), and added my own calls to add in my own geometry dynamically and then write out the .u3d file. All of this is in a C++ class wrapper that my main can now call with geometry to be included.

    My problem is that it all compiles okay but the linker fails giving me a
    fatal error LNK1104: cannot open file 'libmmt.lib'

    libmmt.lib is not on my machine and I believe it's required for some of the U3D libraries but if it's not on my machine anywhere, how did the libraries get built to begin with? I tried changing some of my compiler/linker directives but still get the same error which leads me to belive it's a U3D library need.

    Does anyone have any guidance?

    Thanks in advance,
    TJ

     
  • Michail Vidiassov

    If you google around, you'll see that libmmt looks like a name of an Intel math library,
    that can _optionnally_ be used by U3D libs.
    Check you build settings/environment.
    Sorry, no specific advice since I have moved from Intel build tools for U3D lib long time ago.
    You may use my cmake project to produce VS one.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks