Problem using the rendering engine

  • developerguy personguy

    I am trying to use the U3D rendering library, but so far it is refusing to work. I've tried creating a device, connecting ti to a view and a window and then telling it to Render(). However I get back a "not_supported" error (0x80000001). I am trying to render with openGL and the renderingServices object tells me that it does support OpenGL.

    I've also tried to run the sample projects included in the source. I built the projects created by the perl script but they won't render either. Most noticeable problem is that the assert on line 538 (u3dviewerwin.cpp) fails with an "INVALID_RANGE" error (0x80000006):


    Also, the rendering call on line 1901 fails with the same error (0x80000006):

    if (IFXSUCCESS(result))       
            result = m_pDevice->Render();

  • angevad

    angevad - 2012-04-12

    I can't find any source files for compile IFXRendering library in U3D project. Anybody know way for compile IFXRendering project?


Log in to post a comment.