Devices that this software works on

  • Julian Eden

    Julian Eden - 2010-02-19

    Please enter in your devices details and whether it worked or not.  Something like:

    Manufacturer: Sandisk
    Model: Cruzer Titanium 16GB
    Serial: #######

    Worked perfectly / Couldn't get it to recognize the device …

  • Julian Eden

    Julian Eden - 2010-02-19

    Manufacturer: Sandisk
    Model: Cruzer Titanium 16GB

    Worked perfectly.  Used it to get rid of the CDROM partition.

  • Dan Nelson

    Dan Nelson - 2010-08-03

    Manufacturer: Sandisk
    Model: Cruzer Micro Skin 8GB
    Serial: 4527120C5B036B30

    It's vendorid 0x0781, productid 0x5151.  Adding those entries to the u3_dev_list array makes the 'scan' keyword work.

  • Anonymous

    Anonymous - 2011-02-26

    I would also like the USB Vendor ID and Product ID so i can extend the vid:pid list in the libusb subsystem.

    Thanks ideahamster for setting up this compatibility thread.
    Thanks dnelson for your vid:pid, I added them to the source.

  • Anonymous

    Anonymous - 2011-02-27

    The devices i test on during development:

    Manufacturer: Sandisk
    Model: Cruzer Pattern 2GB
    usbid: 0781:550a

    Manufacturer: Sandisk
    Model: Cruzer Micro 4GB
    usbid: 0781:5406

  • Anonymous

    Anonymous - 2011-03-05

    SanDisk  Ultra Backup 16G
    idVendor=0781, idProduct=5535

    I played with creating/deleting/loading the CD partition. It seemed to wrok perfectly.

  • ahflirt

    ahflirt - 2011-03-23

    Cruzer Micro 16gb

    Tried to unlock the drive due to password lock. DOES NOT WORK. Keep saying drive is blocked. All my important documents are in there. help

  • Anonymous

    Anonymous - 2011-04-18

    ID 0781:5406 SanDisk Corp. Cruzer Micro U3 (8GiB)
    self compiled linux version - works fine

    u3_tool debug info:
    Chip info:
    - Manufacturer: SanDisk  
    - Revision: 80140002

  • happypickle

    happypickle - 2011-05-13

    More general question - does Sandisk have any drives yet with new, U3-incapable controllers?

    Thankfully a lot of non-U3 drives that support u3-tool are still out there.  I recently got a few SDCZ6-4096-A11 from an Amazon-fufilled reseller with working U3.

  • happypickle

    happypickle - 2011-05-18

    To partially answer my own question:  The 16GB sticks at costco do not have U3 controllers.  Still a nice deal at $30, tho.

  • Rune K. Svendsen

    I just tried out my newly-received SanDisk Ultra Backup 8GB (SDCZ40-008G / Vendor ID: 0x0781, Product ID 0x5535) and it seems to work perfectly, although it's really slow (compared to a Corsair Flash Voyager). Creating a new CD-ROM partition works, and writing a 1.2GB DVD ISO to that partition works as well, and I can boot from this "USB CD-ROM" drive.
    Booting this BartPE DVD ISO doesn't get me into Windows XP correctly though (gives me a 0x0000007B error), but the boot menu shows up fine, so I suspect this isn't related to the USB stick.

    • Pankaj

      Pankaj - 2014-09-15

      Hello Rune,

      I also required such kind of function in my application, which allows me to autoplay my app. file when USB is plugged in my system. That might be solved by using this kind of CD-ROM partition in USB drive as it can possible to autorun from CD-ROM drive on detelction in windows system, as per I searched over internet.

      But I want to know that as the support for U3 has been ended by sandisk, this CDROM partition can also available for newly purchased 'SanDisk Ultra Backup' UFD or not.

      Last edit: Pankaj 2014-09-15
  • idansimi

    idansimi - 2011-11-04

    Hi i need help , and want to know if this software will help me…..experts please help :)
    i have U3 Smart Cruzer micro 2 GB
    i made a misstake typing the password since the keybord was Numlk
    i know the password !! just need one more attempt
    to type it , curently the software providing me only the ability to eares the driver
    is there a way to get one more attempt ?
    please help !!!

  • blueskin1978

    blueskin1978 - 2012-01-11

    Manufacturer: Kingston
    Model: DTIU3 1GB
    Serial: 010307

    Worked perfectly with -p 0 x

  • Oliver Schneider

    Those did _not_ work:

    (2 different keys, exactly same serial, 4 GB model)
    P:  Vendor=0781 ProdID=5567 Rev=02.00
    S:  Manufacturer=SanDisk
    S:  Product=Cruzer Blade
    S:  SerialNumber=2243310C9FF1971B

    (4GB model)
    P:  Vendor=0781 ProdID=5567 Rev=02.00
    S:  Manufacturer=SanDisk
    S:  Product=Cruzer Blade
    S:  SerialNumber=4526920C9FF1966A

    (8GB model)
    P:  Vendor=0781 ProdID=5567 Rev=01.02
    S:  Manufacturer=SanDisk
    S:  Product=Cruzer Blade
    S:  SerialNumber=20044322730A3B7251C8

    (2GB model)
    P:  Vendor=090c ProdID=1000 Rev=11.00
    S:  Manufacturer=USB
    S:  Product=DISK Pro
    S:  SerialNumber=AA04012700008161

    (4GB model)
    P:  Vendor=1e68 ProdID=0006 Rev=11.00
    S:  Manufacturer=Trekstor
    S:  Product=USB-Stick QU
    S:  SerialNumber=AA86652700000265

  • Oliver Schneider

    Fascinating, I have three Cruzer Micro 2 GB here and two don't work, while one works.

    The one that works:

    P:  Vendor=0781 ProdID=5406 Rev=02.00
    S:  Manufacturer=SanDisk
    S:  Product=U3 Cruzer Micro
    S:  SerialNumber=077452081540CBEB

    The two that don't

    P:  Vendor=0781 ProdID=5406 Rev=00.10
    S:  Manufacturer=SanDisk Corporation
    S:  Product=U3 Cruzer Micro
    S:  SerialNumber=0000184444707F7F

    P:  Vendor=0781 ProdID=5406 Rev=00.10
    S:  Manufacturer=SanDisk Corporation
    S:  Product=U3 Cruzer Micro
    S:  SerialNumber=000018444470BED0

    I'm flabbergasted. How can that be?

  • Oliver Schneider

    LPInstaller.exe can treat those drives fine, so I'm going to investigate exactly what it sends down to the device ;) … will report back later.

  • Oliver Schneider

    Hi again,

    what does it take to get in touch with the developer of this tool? I'm asking because I wrote a little debugger (based on PyDbg) to investigate the contents of the SCSI pass through requests the LPInstaller.exe of Sandisk sends to the device which works. This still needs some honing, but it works quite well already and it will allow insight into what gets sent and received in order to allow to mimic it.

  • Christopher

    Christopher - 2013-03-29

    I couldn't Load the .exe and cmd flashes up then disappears on three different windows 7 pcs one running 64 bit and the other 2 32 bit please inform me of how to make the program works greatful for any response

  • James Thomas

    James Thomas - 2013-03-31

    I have downloaded the u3tool but have been unsuccesful in locating the WinXP command to unlock my Sandisk Cuzer 4GB drive.  Anyone know the command?  I would love to be able to report back with successful results.

  • Smokey Behr

    Smokey Behr - 2016-10-31

    SanDisk Cruzer Micro (2GiB)


    The CD partition showed up as I, and the rest as J. Pointed the script at I, and it worked as intended. A message popped up asking to format, which I did.

  • charpentier

    charpentier - 2017-08-30

    Help me to rebuild the cd-rom of my usb u3 16giga sandisk cruzer. I format and I lost the drive.


Log in to post a comment.