Many Problems with Typo3Winstaller

  • new2typo3

    new2typo3 - 2006-10-05

    I am a newbie (but with a brain).  I have a strong networking & computing background, but limited knowledge of php & mysql (took a 3 month night school course that ended this past August).  I have done a fair amount of research on various CMSs and am convinced that Typo3 is the one I need and want to use.  However, I am having one hell of a time installing it!  I seem to get lost looking for guidance and answers to my questions in the various forums available, or I receive no replies to my questions (maybe because I am a newbie).  At any rate, I am very anxious to actually get started using the program, if I can just get past the installation and configuration.  If you would be so kind as to provide me with some guidance that would be greatly appreciated.

    Here is what I am working with and what I have done so far:

    1. Windows XP Pro (sp2) – up-to-date
    2. I had previously installed IIS, php 5.1.4 and MySQL 5, but have since disabled both services (although I did not delete my C:\php folder)
    3. I downloaded and installed (successfully) the Typo3Winstaller 4.0.2.  Using Dummy mode, I can view the phpinfo file (it’s the right one because the version is 5.1.6) and get into phpMyAdmin with no problems, however, the install tool is another story.
    4.When I try to access the installer, first I see this popup that reades:

    "SECURITY:  Make sure to protect the Install Tool with another password than "joh316".  Better yet you can add a die() function call to the typo3/install/index.php after usage.

    IF THE INSTALL TOOL CRASHES...  The Install Tool is checking PHPs support for image formats.  However certain verstion os PHP (fx. 4.3.0 with bundeled GD) will crash when trying to read teh PNG test file.  If this happens you will see a blank screen or error message.  Workaround:  Open the file typo3/sysext/install/mod/class.tx_install.php, go to the line where the function "is9PNG()" is defined and make it return "0" hardcoded.  PNG is not checked anymore and the rest of hte Install Tool will work as expected.  The same has been known with the other image formats as well.  You can use a similar method to bypass the testing if that is also a problem.  On behalf of PHP we regret this inconvenience.  BTW: This Install Tool will only work if cookies are accepted by your browser.  If this dialog pops up over and over again you didn't enable cookies."

    Now I am pretty certain that cookies and javascript are enabled, as far as I can tell, because I can do my online banking (for example) and our own website uses javascript and I don’t have any problems there.  So I click “OK” and ignore the message.

    It then prompts me to change the password, but when I do, it will not accept my password.  After several attempts at carrying out the instructions in the message, and several uninstalls and re-installs, I finally found a post on some forum, with a simple solution to append “&password=typo3” to the URL I am trying to access (in this case the Basic Configuration page).  Here is the URL (with appendage):  http://localhost/typo3/typo3/install/index.php?TYPO3_INSTALL\[type]=config&password=typo3.  The problem with this workaround is it only works for the first couple of pages (namely the Basic Configuration and the Database Analyzer), and nothing after that.

    I also cannot access the backend.  For some reason, the user name and password provided “typo3” in both cases, do not work.  I also tried admin/password, respectively to no avail.  I’ve tried editing the $TYPO3_CONF_VARS['BE']['installToolPassword'] in typo3conf/localconf.php with the md5() hash value of my new password and that that doesn’t work either.



    • Andreas Eberhard

      Hi Natalie,

      normally it shold all work.

      Ensure that no other IIS/Apache/Mysql is running.
      Install Typo3Winstaller to a directory without spaces in Path.

      Then ry again. Use the typo3start.exe to start the Servers and to start http://localhost.
      Use the links in the Starting-Page to go to the Install-Tool or to the Backend.

      Good Luck !

    • new2typo3

      new2typo3 - 2006-10-06

      Hi Andreas,

      When I read your reply I was delighted to see that there was a very simple idiosyncrasy that would fix the problem.  So, I uninstalled and reinstalled again, because I didn't realize that Typo3 had to be installed into a directory without spaces (I previously had it installed in the default - which you may want to change) C:\Program Files. 

      The program is now installed in C:\Typo3.  However, same problem exists.  As you can imagine, it let the wind out of my sails pretty quickly and I am back to extremely frustrated.

      Is it possible that, when I uninstalled typo3winstaller, that something may have been left in windows registry that might be affecting my results?

      What other information can I provide to you that may help troubleshoot this problem.

      P.S. I am bound and determined to find the answer, because I really want this program to work!


    • new2typo3

      new2typo3 - 2006-10-06

      Further to my previous thread ... I have been doing a little more digging in an effort to give you something to work with.


      Perhaps this will help.  I get to the basic configuration page without going through the Step 1 - 2 - 3 in Kasper's video. 

      But as mentioned above, can't do anything beyond that.  However, if I change my password, I am redirected to an error page

      (http://localhost/typo3/typo3/install/index.php?TYPO3_INSTALL[type]=extConfig) that askes me to enter the Install Tool password (without a user name, just a password).  Here is the response I get:

      "Enter the Install Tool password [Login]

      The Install Tool Password is not the admin password of TYPO3.
      If you don't know the current password, you can set a new one by setting the value of $TYPO3_CONF_VARS['BE']

      ['installToolPassword'] in typo3conf/localconf.php to the md5() hash value of the password you desire."

      When trying various suspected passwords (i.e. "password"; "joh316"; "typo3"), sometimes, the error message above appears, but with the following appended at the end:

      "The password you just tried has this md5-value:

      except that the MD5 hash value changes each time I try a new/different password.  Interestingly enough, the MD5 has values do not always match up with the passwords that I try.  For example:

      The hash value for joh316 (contrary to the comment in the localconf.php file) is NOT "dc117c9322deb502c3b16769a8a64e08" but rather IS "bacb98acf97e0b6112b1d1b650b84971".  in fact, the MD5 value of "dc117c9322deb502c3b16769a8a64e08" is for the
      password "typo3" - which is what the password is supposed to be according to the localhost default page. 

      If I enter a completely different password such as "unlucky" it displays the message above again, with its corresponding MD5

      hash value of "dc117c9322deb502c3b16769a8a64e08" (in this case the password & MD5 value match).


      Now I have never used Apache before installing Typo3, and I am not certain of what directory the default webpage is located in, although I suspect it is \htdocs (upon viewing the index.php file therein).  In "trying" (being the operative word here) to follow the code in that file, I noticed that lines 45 & 47 (hyperlinks for the backend and the install tool, respectively), point to:

      Line 45 - ./typo3/typo3/index.php
      - and -
      Line 47 - ./typo3/typo3/install/index.php?password=typo3

      However, the installer creates the following directory structure in C:\Typo3_4.0.2 (which I renamed to C:\Typo3):


      so what file is it actually reading?

      I'm not sure if I need to add a specific path to my windows path variable, or if any of this is even close to being helpful.

      Hope this info is helpful in troubleshooting.



    • Paul_Tabo

      Paul_Tabo - 2007-02-10

      I sure wish I could help, but I'm just waiting for a solution to your problem.  I do not know as much as I would like to about the install procedure.  Many times software directions tell one to go next to A then B then C without telling one about the B1,B2 and B3 parts they gloss over.  I suspect that using the stand alone "dummy" version may be part of the problem.  If you really want Typo3 then get out of this version, clean your system and go to one of the other versions since they may have better support.  I'm waiting and watching what happens. I hope we get help.  Best wishes (there shouldn't be any luck needed with programs).  There should be a preview before posting here ... but.. well ... that's all.

    • Paul_Tabo

      Paul_Tabo - 2007-02-10

      Well, I went and decided to take a chance when I saw the x.0.2 version.  So far worked like a charm no problems really like the short cut with selectable options - - - really super and good idea.  Now to figure out what to do with it after playing around I just may use it on a rented website  :>)
      I'll have to look at the passwords requirements, and also some terminology such as front door and back end (What are they?).  I made a date for dancing tonight ...darn ... to late to cancel out!


Log in to post a comment.