mpi not found

o_wild
2011-08-24
2013-04-16
  • o_wild

    o_wild - 2011-08-24

    Hi,
    When I run configure.sh, the message shows that mpi library is not found. But I have installed mpich2.Strangely, it have not the static library mpich2.a as expected but some dynamic ones (libmpich.so.1.2,libmpichf90.so.1.2) and other static ones(libampe.a,liblmpe.a,libmpe.a,libmpe_collchk.a,libmpe_f2cmpi.a…)
    May I need to modify the configure script? Is the version of my mpi not compatible?


    TYPHON configuration

    checking native system …                     Linux
    checking CPU model …                         i686
    checking echo command …                      echo
    checking diff command …which: no ndiff in (/usr/lib/mpich2/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/wzh/bin)
                                                   /usr/bin/diff
    checking fortran 90 compiler …               /usr/bin/f95
    checking f95 fortran 90 conformance …        successfully compiled
                                                   checked
    checking static library cgns …               /usr/local/lib/libcgns.a
    checking static library metis …              /usr/local/lib/libmetis.a
    checking static library mpi …            @@@ not found: libmpi.a
    checking static library mpich …          @@@ not found: libmpich.a
    checking static library lampi …          @@@ not found: liblampi.a
    checking static library mpi_f90 …        @@@ not found: libmpi_f90.a
    checking include file cgnslib_f.h …          /usr/include/cgnslib_f.h
    checking include file mpif.h …           @@@ not found: mpif.h
    checking MPI library …                   @@@ not found
    checking f95 optimization options …          -03
    checking f95 optimization …                  successfully compiled
                                                   checked
    checking f95 debug options …                 -g
    checking f95 debug …                         successfully compiled
                                                   checked
    checking f95 profiling options …             -03 -pg
    checking f95 profiling …                     successfully compiled
                                                   checked
    checking fortran 90 module creation …        extension mod
                                                   lower-case name
    !!! warning !!! MPI    not available: TYPHON will not feature parallel computation
    TYPHON configuration help
      set TYPHONPATH to help finding external libraries and include files (i.e. export TYPHONPATH=/my_usr:/opt/aero)
      . libraries     will be searched in $TYPHONPATH/lib
      . include files will be searched in $TYPHONPATH/include
    Configuration ended
    Writing Shell configuration (bin/shconf.sh)…
    Writing Makefile configuration (config/arch.make)…
    Done


    to build TYPHON : make all

    Best regards
    o_wild

     
  • Jeremie Gressier

    hi,

    MPI is less and less easy to configure oneself for compilation and link. We now should directly use mpif90 (which is not yet configured there).
    To produce MPI code, I usually directly edit config/arch.make and change MPILIB variable with the right option. For example with openmpi, instead of a simple -lmpi, I need

    MPILIB      = -pthread -I/opt/aero/x86_64-Linux/lib -L/opt/aero/x86_64-Linux/lib -lmpi_f90 -lmpi_f77 -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl
    

    !!!
    I hope that (as I did) you can get these parameters with

    mpif90 --showme:link
    

    maybe it depends on your mpi implementation

    Hope it helps

    JGressier

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks