Testing now.  First off, the splash screen within Tux Paint still
says 0.9.15 from 2005.11.25.  I see your About screen has the right
version (although the build seems to be from a few days in the future ;^) )

Splash screen fixed.  (I like to stay ahead of things on the build date :-) )

Secondly, Chinese (both), Japanese and Korean are ALL showing up as squares.
Can you perhaps try using an older SDL_ttf, like John is on Win32, and
see if these locales render properly for you?

Hmm... including SDL_ttf 2.0.6 doesn't help.  I also ran Tux Paint 0.9.14 and 0.9.15 and I also get the squares with the Korean language selected, so the problem may have been around for quite a while on the Mac side of things.  

I tried playing with locale settings in the Mac's System Preferences
dialog, and some worked, some didn't seem to do anything, except pick the
next option down the list (e.g., if I moved Portuguese to the top of
the list in the Mac's settings, Tux Paint would end up using the next
language down... other languages worked properly, e.g., Hebrew)

Do you know how Tux Paint reads the language settings from the Mac System preferences.  Via an environment variable? settings file?  I perused through the code but can't seem to find the spot where  the Mac language settings are read...

One more issue.  It seems the locale is not being kept track of inside
Tux Paint.  If I change the locale to Catalan in Tux Paint Config,
the UI text is all Catalan, which is correct.

However, none of the stamps play their descriptive (spoken) sounds,
when I click them.

e.g., when I click the Rooster stamp, I do not hear "rooster_desc_ca.ogg"
play after "rooster.ogg" plays.

Additionally, when I click the number stamps (i.e., "0.png" thru "9.png"),
I get the english sounds (e.g., "0_en.png"), rather than the Catalan
ones (e.g., "0_ca.png").

It works fine for me, after using Tux Paint Stamps installer to install stamps for the "Current User". This evening I updated the Tux Paint Stamps XCode project, as it was placing both the stamps gzip file and the unzipped stamps directory into the installer bundle, making the installer twice as large as it should be.  I doubt this would have affected proper installation of the stamps, however.  Maybe try compiling this latest installer and running it, just in case it solves the problem for you...   

Ok, one more, then I'm done.  ANy reason you include only the english
plain-text (TXT) version of the documentation, and not the HTML docs
(either instead of, or as well as the plain-text)?

I'll throw in the HTML docs as well!  Alternatively, I could include the HTML and/or text documents inside the Tux Paint application bundle and make them accessible via the Help menu (from the Mac menubar).