mmcache.php dead lock!

Help
Anonymous
2003-06-13
2003-06-19
  • Anonymous - 2003-06-13

    When I refresh my IE. My apache stop responding to any php requests! (static html and images are OK)

     
    • Anonymous - 2003-06-13

      I refresh as fast as once or two a second!

       
    • Dmitry Stogov

      Dmitry Stogov - 2003-06-16

      Can you tell me the version string in the bottom of output of "mmcache.php" and may be I will help.

       
    • Ingo Theiss

      Ingo Theiss - 2003-06-16

      The same happens to me!

      Shortly after refreshing mmcache.php the apache webserver stops responding.

      Here ist my version string:

      MMCache 2.3.15 [shm:sysvipc sem:spinlock], PHP 4.3.2 [ZE 1.3.0], Apache [Apache/1.3.27 (Unix) PHP/4.3.2 mod_ssl/2.8.14 OpenSSL/0.9.7a

      PS: I have suggestion to enhance the output from mmcache.php. In my opinion it is not reasonable to print out all cached files. Averaged my installtion of MMCache buffers 2500 -3000 files. The output is horrible long and useless in that amount. A summary like at top would fit the needs. Maybe an extra button for displaying all cached files makes more sense.

       
    • Dmitry Stogov

      Dmitry Stogov - 2003-06-17

      Please, try to rebuild mmcache with ollwing instruction:

      $ phpize
      $ ./configure --with-mmcache=shared
      edit config.h
        comment #define MM_SEM_SPINLOCK 1
        change   /* #undef MM_SEM_IPC */
               to   #define MM_SEM_IPC 1
      $ make
      # make install

      Let me know if it will help or not.

       
      • Anonymous - 2003-06-19

        I tried this. It seems to work. but is it safe?

         
        • Dmitry Stogov

          Dmitry Stogov - 2003-06-19

          I hope :)

           
    • Ingo Theiss

      Ingo Theiss - 2003-06-18

      Hello Dmitry,

      sorry but I wasnt able to try your suggestion. Yesterday we had serious trouble again and I had to disable MMCache.

      I have a bad suspicion:

      Our server is a dual xeon 2.4 GHz with 2 GB RAM and 256 MB reserved for MMCache. At about 19:38h we got tons of critical kernel messages in syslog! After research I found out that about 1.75 GB RAM were in use and system started heavy swaping. I think the system tryed to access or use memory from the shared memory segment reserved for mmcache! The kernel had thrown tons of messages like: "Null pointer exception trying to access virtual memory at adress xxx".
      Ive disabled MMCache and deleted the shared memory segment and the kernel stopped reporting errors.

      Is it likely that MMCache hat to do with the problem? Or maybe the MM shared memory library? Fact is the problem started when all available memory except of shared memory was used and ended after deleting the shared memory segment and disabling MMCache ;-((

       
      • Dmitry Stogov

        Dmitry Stogov - 2003-06-18

        I have found the problem and fixed it.
        Fixed version is available in sourceforge CVS and will be available in the next release (2.3.16)

         
        • Anonymous - 2003-06-19

          Thanks, wondful job!
          Thanks again!

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks